Last Comment Bug 720190 - In pymake, the UnexportDirective class is missing a dump() method
: In pymake, the UnexportDirective class is missing a dump() method
Status: RESOLVED FIXED
[pymake]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Michael Haggerty
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-21 21:44 PST by Michael Haggerty
Modified: 2012-01-23 10:32 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch that adds UnexportDirective.dump() (742 bytes, patch)
2012-01-21 21:44 PST, Michael Haggerty
benjamin: review+
Details | Diff | Splinter Review

Description Michael Haggerty 2012-01-21 21:44:56 PST
Created attachment 590538 [details] [diff] [review]
Patch that adds UnexportDirective.dump()

If you run mkparse.py against a Makefile that contains an "unexport" statement, an exception is thrown:

Traceback (most recent call last):
  File "../pymake/mkparse.py", line 12, in <module>
    print stmts
  File "/home/mhagger/self/proj/pymake-hg/pymake/parserdata.py", line 510, in __str__
    self.dump(fd, '')
  File "/home/mhagger/self/proj/pymake-hg/pymake/parserdata.py", line 506, in dump
    s.dump(fd, indent)
AttributeError: 'UnexportDirective' object has no attribute 'dump'

The exception is caused by the fact that UnexportDirective does not implement the dump() method.

I will attach a patch that fixes the problem.
Comment 1 Benjamin Smedberg [:bsmedberg] 2012-01-22 10:51:13 PST
Comment on attachment 590538 [details] [diff] [review]
Patch that adds UnexportDirective.dump()

Please push to the pymake repo and we'll get pick this up in m-c the next time we do an import (unless it's really important to you that we get it into the mozilla tree).
Comment 2 Michael Haggerty 2012-01-22 23:51:43 PST
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #1)
> Please push to the pymake repo and we'll get pick this up in m-c the next
> time we do an import (unless it's really important to you that we get it
> into the mozilla tree).

There is no hurry on my account to get this in the mozilla tree; I have patched my copy locally and that is fine for now.

I am not a committer to pymake so I don't believe that I can push to the project.  (Therefore the bug should probably not remain assigned to me, but I don't know to whom I should assign it.)
Comment 3 Ed Morley [:emorley] 2012-01-23 04:01:17 PST
That's ok, someone else can land it for you (I have marked the bug as checkin-needed, so will be picked up by myself/someone else soon). What first+last name do you wish to have on the commit?
Comment 4 Ed Morley [:emorley] 2012-01-23 04:01:58 PST
(And thank you very much for the patch!)
Comment 5 Michael Haggerty 2012-01-23 04:23:45 PST
(In reply to Ed Morley [:edmorley] from comment #3)
> [...] What first+last name do you wish to have on the commit?

Michael Haggerty

(In reply to Ed Morley [:edmorley] from comment #4)
> (And thank you very much for the patch!)

My pleasure.  pymake is quite cool and I expect it to save me a lot of work on a project that I am working on.
Comment 6 Benjamin Smedberg [:bsmedberg] 2012-01-23 10:30:08 PST
http://hg.mozilla.org/users/bsmedberg_mozilla.com/pymake/rev/87d436cd8974

Thanks for the patch!

Note You need to log in before you can comment on or make changes to this bug.