Add toggle-feature for about:config on boolean preference entries

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: eagle3386, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:12.0a1) Gecko/20120116 Firefox/12.0a1
Build ID: 20120116031100

Steps to reproduce:

- open about:config
- select an entry of boolean type, e.g. browser.menu.showCharacterEncoding
- open context-menu


Actual results:

- several entries, but no "toggle-entry"


Expected results:

- either a) add an toggle-entry or b) replace "Modify" with "Toggle" on boolean entries
- double-clicking a boolean entry should toggle the value, too
(Reporter)

Updated

7 years ago
Component: Untriaged → Preferences
Hardware: x86 → x86_64
Version: 12 Branch → Trunk
(Reporter)

Comment 1

7 years ago
If it's possible, I'd like to fix this bug for Mozilla.

Comment 2

7 years ago
browser.menu.showCharacterEncoding is "false", saved as a string (look at the type). Real booleans do have a toggle option (e.g. app.update.auto).
(Reporter)

Comment 3

7 years ago
Oh, boy. I'm so embarrassed.. :o)

Resolved, because it's invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Component: Preferences → General
Product: Firefox → Toolkit
QA Contact: untriaged → general
You need to log in before you can comment on or make changes to this bug.