Closed Bug 720293 Opened 11 years ago Closed 11 years ago

"Auto-completing" address bar changes the behavior of backspace

Categories

(Firefox :: Address Bar, defect)

12 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 719890

People

(Reporter: jstpierre, Unassigned)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:12.0a1) Gecko/20120121 Firefox/12.0a1
Build ID: 20120121121718

Steps to reproduce:

1. Enter "m" into the address bar, so that "mozilla.com" is auto-completed.
2. Press backspace.


Actual results:

"m"


Expected results:

""

--

This regresses the behavior of the backspace key so it's considerably annoying having to hit backspace twice to erase some characters.
Confirmed on
http://hg.mozilla.org/mozilla-central/rev/244711942710
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120122 Firefox/12.0a1 ID:20120122031050
Blocks: 566489
Status: UNCONFIRMED → NEW
Component: Untriaged → Location Bar
Ever confirmed: true
Keywords: regression
QA Contact: untriaged → location.bar
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 719890
You need to log in before you can comment on or make changes to this bug.