Last Comment Bug 720408 - Exception handling message "Tab:ScreenshotData": java.lang.StringIndexOutOfBoundsException
: Exception handling message "Tab:ScreenshotData": java.lang.StringIndexOutOfBo...
Status: RESOLVED FIXED
: regression
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P2 normal (vote)
: Firefox 13
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-23 10:20 PST by Aaron Train [:aaronmt]
Modified: 2012-02-06 09:23 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
11+


Attachments
Raw log (Nightly 01/23) (25.94 KB, text/plain)
2012-01-23 10:20 PST, Aaron Train [:aaronmt]
no flags Details
patch (1.02 KB, patch)
2012-01-30 21:35 PST, Brad Lassey [:blassey] (use needinfo?)
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Review

Description Aaron Train [:aaronmt] 2012-01-23 10:20:34 PST
Created attachment 590773 [details]
Raw log (Nightly 01/23)

I/GeckoApp( 3910): Got message: Tab:ScreenshotData
E/GeckoApp( 3910): Exception handling message "Tab:ScreenshotData":
E/GeckoApp( 3910): java.lang.StringIndexOutOfBoundsException: length=6; index=22
E/GeckoApp( 3910): 	at java.lang.String.indexAndLength(String.java:589)
E/GeckoApp( 3910): 	at java.lang.String.substring(String.java:1448)
E/GeckoApp( 3910): 	at org.mozilla.gecko.GeckoApp.handleMessage(GeckoApp.java:924)
E/GeckoApp( 3910): 	at org.mozilla.gecko.GeckoAppShell.handleGeckoMessage(GeckoAppShell.java:1616)
E/GeckoApp( 3910): 	at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
E/GeckoApp( 3910): 	at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
E/GeckoApp( 3910): 	at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:483)
E/GeckoApp( 3910): 	at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:104)


--
Samsung Nexus S (Android 4.0.3)
Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20120123 Firefox/12.0a1 Fennec/12.0a1
Comment 1 Brad Lassey [:blassey] (use needinfo?) 2012-01-30 21:35:06 PST
Created attachment 592984 [details] [diff] [review]
patch
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-30 21:43:24 PST
Comment on attachment 592984 [details] [diff] [review]
patch

Why would we get into this state? Is an empty string coming back?

If you know, can you add a comment above the new if check?
Comment 3 Brad Lassey [:blassey] (use needinfo?) 2012-01-31 10:07:50 PST
(In reply to Mark Finkle (:mfinkle) from comment #2)
> Comment on attachment 592984 [details] [diff] [review]
> patch
> 
> Why would we get into this state? Is an empty string coming back?
> 
> If you know, can you add a comment above the new if check?

not an empty string, but looks like empty data from the log. I suspect that getting the data from the canvas failed (possibly because drawing to it failed) and we're just getting a string with "data:".
Comment 4 Ed Morley [:emorley] 2012-02-01 11:24:34 PST
https://hg.mozilla.org/mozilla-central/rev/396945d35979
Comment 5 Brad Lassey [:blassey] (use needinfo?) 2012-02-02 14:21:32 PST
Comment on attachment 592984 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Low volume crash from unknown cause. We weren't able to reproduce
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Comment 6 Alex Keybl [:akeybl] 2012-02-05 13:39:51 PST
Comment on attachment 592984 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora 12 and Beta 11.
Comment 8 Mark Finkle (:mfinkle) (use needinfo?) 2012-02-06 09:23:25 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/cc433916cd1d

Note You need to log in before you can comment on or make changes to this bug.