Last Comment Bug 720442 - When scrolling input fields into view, scroll them to just above keyboard instead of top of screen
: When scrolling input fields into view, scroll them to just above keyboard ins...
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All Android
: P2 normal (vote)
: Firefox 12
Assigned To: Kartikaya Gupta (email:kats@mozilla.com)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-23 11:19 PST by Kartikaya Gupta (email:kats@mozilla.com)
Modified: 2012-02-01 09:41 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
11+


Attachments
Simplest patch ever (1.26 KB, patch)
2012-01-26 08:23 PST, Kartikaya Gupta (email:kats@mozilla.com)
blassey.bugs: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Kartikaya Gupta (email:kats@mozilla.com) 2012-01-23 11:19:34 PST

    
Comment 1 Kartikaya Gupta (email:kats@mozilla.com) 2012-01-26 08:23:53 PST
Created attachment 591812 [details] [diff] [review]
Simplest patch ever

Tested manually using http://people.mozilla.org/~kgupta/bug/696319.html and random web content
Comment 2 Brad Lassey [:blassey] (use needinfo?) 2012-01-26 09:33:45 PST
Comment on attachment 591812 [details] [diff] [review]
Simplest patch ever

Review of attachment 591812 [details] [diff] [review]:
-----------------------------------------------------------------

well... that was easy :-)
Comment 3 Kartikaya Gupta (email:kats@mozilla.com) 2012-01-26 10:18:21 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/5eb7ad98588a
Comment 4 Marco Bonardo [::mak] 2012-01-26 16:26:36 PST
https://hg.mozilla.org/mozilla-central/rev/5eb7ad98588a
Comment 5 Kartikaya Gupta (email:kats@mozilla.com) 2012-01-27 07:33:35 PST
Comment on attachment 591812 [details] [diff] [review]
Simplest patch ever

[Approval Request Comment]
Regression caused by (bug #): none
User impact if declined: input fields get scrolled to top of viewport which can be annoying
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): mobile only
Comment 6 Alex Keybl [:akeybl] 2012-01-27 16:17:40 PST
Comment on attachment 591812 [details] [diff] [review]
Simplest patch ever

[Triage Comment]
Mobile only - approved for Aurora.
Comment 7 Brad Lassey [:blassey] (use needinfo?) 2012-01-30 11:41:36 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/152072bca69c
Comment 8 Andreea Pod 2012-02-01 09:41:10 PST
Verified fixed on

Aurora: Mozilla /5.0 (Android;Linux armv7l;rv:11.0a2) Gecko/20120131 Firefox/11.0a2 Fennec/11.0a2
Nightly: Mozilla /5.0 (Android;Linux armv7l;rv:12.0a1) Gecko/20120201 Firefox/12.0a1 Fennec/12.0a1

Device: LG Optimus 2X (Android 2.2)

Note You need to log in before you can comment on or make changes to this bug.