Last Comment Bug 720505 - MarkRuntime should not be exposed in jsapi.h
: MarkRuntime should not be exposed in jsapi.h
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla12
Assigned To: Bill McCloskey (:billm)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-23 13:57 PST by Bill McCloskey (:billm)
Modified: 2012-01-25 07:27 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (3.44 KB, patch)
2012-01-23 13:57 PST, Bill McCloskey (:billm)
Ms2ger: review+
Details | Diff | Splinter Review

Description Bill McCloskey (:billm) 2012-01-23 13:57:50 PST
Created attachment 590861 [details] [diff] [review]
patch

It looks like the friend declarations for MarkRuntime are not necessary. Since MarkRuntime is a GC-internal function, it would be better not to expose it.
Comment 1 :Ms2ger (⌚ UTC+1/+2) 2012-01-24 01:57:16 PST
Comment on attachment 590861 [details] [diff] [review]
patch

If it passes try, lgtm
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2012-01-25 07:27:52 PST
https://hg.mozilla.org/mozilla-central/rev/040975f3210a

Note You need to log in before you can comment on or make changes to this bug.