Closed Bug 720509 Opened 8 years ago Closed 8 years ago

java.lang.NullPointerException at org.mozilla.gecko.GeckoApp.onPrepareOptionsMenu(GeckoApp.java:487)

Categories

(Firefox for Android :: General, defect, P4, critical)

12 Branch
ARM
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 13
Tracking Status
firefox11 --- affected
firefox12 --- affected
fennec 11+ ---

People

(Reporter: nhirata, Assigned: bnicholson)

Details

(Keywords: crash, reproducible, Whiteboard: [native-crash])

Crash Data

Attachments

(1 file)

From Socorro:

248 Crash count for :

EGL? EGL+
AdapterVendorID: herring, AdapterDeviceID: Nexus S.
AdapterDescription: 'Android, Model: 'Nexus S', Product: 'soju', Manufacturer: 'samsung', Hardware: 'herring''.
java.lang.NullPointerException
	at org.mozilla.gecko.GeckoApp.onPrepareOptionsMenu(GeckoApp.java:487)
	at android.app.Activity.onPreparePanel(Activity.java:2462)
	at com.android.internal.policy.impl.PhoneWindow.preparePanel(PhoneWindow.java:416)
	at com.android.internal.policy.impl.PhoneWindow.onKeyDownPanel(PhoneWindow.java:759)
	at com.android.internal.policy.impl.PhoneWindow.onKeyDown(PhoneWindow.java:1424)
	at com.android.internal.policy.impl.PhoneWindow$DecorView.dispatchKeyEvent(PhoneWindow.java:1813)
	at android.view.ViewRootImpl.deliverKeyEventPostIme(ViewRootImpl.java:3327)
	at android.view.ViewRootImpl.handleFinishedEvent(ViewRootImpl.java:3300)
	at android.view.ViewRootImpl.handleMessage(ViewRootImpl.java:2460)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.lo

473171f1-46a3-4070-8ded-57f882111230
64ec9ff8-89f6-4ceb-814d-8ade22111229
bd9361b3-41ea-4bf8-952e-b3f802120111
c7554b7d-b65c-4a01-816c-a74d42120109


https://crash-stats.mozilla.com/report/index/47bae3e8-abc1-497c-a93c-0fa8e2111225
Assignee: nobody → fabrice
tracking-fennec: --- → 11+
Priority: -- → P4
Severity: normal → critical
Crash Signature: [@ mozalloc_abort | Java_org_mozilla_gecko_GeckoAppShell_nativeRun]
Java signature.  It's hard to tell what's going on without getting a socorro report
Here are crash reports:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A%20at%20org.mozilla.gecko.GeckoApp.onPrepareOptionsMenu%28GeckoApp.java%29
Crash Signature: [@ mozalloc_abort | Java_org_mozilla_gecko_GeckoAppShell_nativeRun] → [@ mozalloc_abort | Java_org_mozilla_gecko_GeckoAppShell_nativeRun] [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp.onPrepareOptionsMenu(GeckoApp.java)]
Steps to reproduce:
1. Open new tab
2. Write anything (ex. mozillane..)
3. Do a Search - press the magnifying glass button
4. Press Menu buttons
Nice work, Ioana!
Keywords: reproducible
Assignee: fabrice → bnicholson
Attached patch patchSplinter Review
When doing a search "foo" in the AwesomeScreen, the tab URL gets set to "foo" before being resolved to a URL. Since this isn't an actual URL, getScheme() will be null.
Attachment #595466 - Flags: review?(mark.finkle)
Comment on attachment 595466 [details] [diff] [review]
patch

hmm, can we try to fix the Tab.getURL to not get set to anything but a URL. I am a little worried that we have a non-URL in the URL field. Could be trouble in other areas of the code.

r+ on this for now
Attachment #595466 - Flags: review?(mark.finkle) → review+
(In reply to Mark Finkle (:mfinkle) from comment #6)
> Comment on attachment 595466 [details] [diff] [review]
> patch
> 
> hmm, can we try to fix the Tab.getURL to not get set to anything but a URL.
> I am a little worried that we have a non-URL in the URL field. Could be
> trouble in other areas of the code.
> 
> r+ on this for now

Filed bug 726080.
https://hg.mozilla.org/mozilla-central/rev/331973a3884e
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 13
Attachment #595466 - Flags: approval-mozilla-beta?
Attachment #595466 - Flags: approval-mozilla-aurora?
Comment on attachment 595466 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora 12 and Beta 11.
Attachment #595466 - Flags: approval-mozilla-beta?
Attachment #595466 - Flags: approval-mozilla-beta+
Attachment #595466 - Flags: approval-mozilla-aurora?
Attachment #595466 - Flags: approval-mozilla-aurora+
Comment on attachment 595466 [details] [diff] [review]
patch

clearing beta approval per akeybl on IRC, No Fennec Native Shipping for Gecko 11
Attachment #595466 - Flags: approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.