Closed Bug 720515 Opened 8 years ago Closed 1 year ago

android.database.CursorIndexOutOfBoundsException: Index <m> requested, with a size of <n> at android.database.AbstractCursor.checkPosition(AbstractCursor.java)

Categories

(Firefox for Android :: General, defect, P4, critical)

17 Branch
ARM
Android
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox17 --- affected
blocking-fennec1.0 --- -
fennec - ---

People

(Reporter: nhirata, Unassigned)

Details

(Keywords: crash, Whiteboard: [native-crash])

Crash Data

508 count in 

EGL? EGL+
AdapterVendorID: smdkc210, AdapterDeviceID: GT-I9100.
AdapterDescription: 'Android, Model: 'GT-I9100', Product: 'GT-I9100', Manufacturer: 'samsung', Hardware: 'smdkc210''.
android.database.CursorIndexOutOfBoundsException: Index -1 requested, with a size of 4
	at android.database.AbstractCursor.checkPosition(AbstractCursor.java:580)
	at android.database.AbstractWindowedCursor.checkPosition(AbstractWindowedCursor.java:214)
	at android.database.AbstractWindowedCursor.getBlob(AbstractWindowedCursor.java:27)
	at android.database.CursorWrapper.getBlob(CursorWrapper.java:143)
	at android.database.CursorWrapper.getBlob(CursorWrapper.java:143)
	at org.mozilla.gecko.AboutHomeContent$TopSitesViewBinder.updateThumbnail(AboutHomeContent.java:332)
	at org.mozilla.gecko.AboutHomeContent$TopSitesViewBinder.setViewValue(AboutHomeContent.java:374)
	at android.widget.SimpleCursorAdapter.bindView(SimpleCursorAdapter.java:126)
	at android.widget.CursorAdapter.getView(CursorAdapter.java:186)
	at a
STR? regrssion range?
Assignee: nobody → lucasr.at.mozilla
tracking-fennec: --- → 11+
Priority: -- → P4
I remember running into this issue once before.  It had to do with the about:home and url bar around the time there were issues with / about:home.  I couldn't reproduce it at the time I ran into the issue.  will have to revisit to try to hit this again.
Keywords: topcrash
Crash Signature: [@ mozalloc_abort | __swrite | dexDataMapAlloc]
Cannot seem to reproduce; 002fe013-7307-482f-b862-3476f2111224 12/20/2012 seems to be the earliest that socorros seems to see the crash; though, that's the same day as the train moving.
Guessing that this is due to the thumbnail in the Top sites column trying to update but the index for that top site is out of bounds in the android database?  Maybe trying to mess with the database in the default web browser when going to the web page in fennec might trigger the crash?  not sure.  Need to play around with the idea.
Java crash; nom-ing for blocking fennec
blocking-fennec1.0: --- → ?
One crash in 13.0a1:
bp-fc8f3d4d-14c1-4a6c-90c6-d528c2120225
Crash Signature: [@ mozalloc_abort | __swrite | dexDataMapAlloc] → [@ mozalloc_abort | __swrite | dexDataMapAlloc] [@ android.database.CursorIndexOutOfBoundsException: Index -1 requested, with a size of 28 at android.database.AbstractCursor.checkPosition(AbstractCursor.java) ]
Not a top crash, not blocking. Still good to fix though.
blocking-fennec1.0: ? → -
Er...it is top crash.
blocking-fennec1.0: - → ?
blocking-fennec1.0: ? → -
Keywords: topcrash
Here is a recent crash (bp-01bc7b47-cdd6-41fc-bdd1-f28e02120421) with a stack slightly different from the one in comment 0:
android.database.CursorIndexOutOfBoundsException: Index -1 requested, with a size of 7
	at android.database.AbstractCursor.checkPosition(AbstractCursor.java:580)
	at android.database.AbstractWindowedCursor.checkPosition(AbstractWindowedCursor.java:214)
	at android.database.AbstractWindowedCursor.getString(AbstractWindowedCursor.java:41)
	at android.database.CursorWrapper.getString(CursorWrapper.java:135)
	at android.database.CursorWrapper.getString(CursorWrapper.java:135)
	at org.mozilla.gecko.db.LocalBrowserDB$DesktopBookmarksCursorWrapper.getString(LocalBrowserDB.java:656)
	at android.database.CursorWrapper.getString(CursorWrapper.java:135)
	at org.mozilla.gecko.AwesomeBarTabs.updateUrl(AwesomeBarTabs.java:946)
	at org.mozilla.gecko.AwesomeBarTabs.access$600(AwesomeBarTabs.java:88)
	at org.mozilla.gecko.AwesomeBarTabs$BookmarksListAdapter.getView(AwesomeBarTabs.java:301)
	at android.widget.AbsListView.obtainView(AbsListView.java:1438)
	at android.widget.ListView.measureHeightOfChildren(ListView.java:1297)
	at android.widget.ListView.onMeasure(ListView.java:1208)
...
Crash Signature: [@ mozalloc_abort | __swrite | dexDataMapAlloc] [@ android.database.CursorIndexOutOfBoundsException: Index -1 requested, with a size of 28 at android.database.AbstractCursor.checkPosition(AbstractCursor.java) ] → [@ android.database.CursorIndexOutOfBoundsException: Index -1 requested, with a size of 28 at android.database.AbstractCursor.checkPosition(AbstractCursor.java) ] [@ android.database.CursorIndexOutOfBoundsException: Index -1 requested with a size of 7 at…
Summary: android.database.CursorIndexOutOfBoundsException: Index -1 requested, with a size of 4 at android.database.AbstractCursor.checkPosition(AbstractCursor.java:580) → android.database.CursorIndexOutOfBoundsException: Index -1 requested, with a size of <n> at android.database.AbstractCursor.checkPosition(AbstractCursor.java)
Version: Firefox 12 → Trunk
One crash in the last 4 weeks bp-7850bf59-fff9-46fc-a89f-e51272121009
tracking-fennec: 11+ → ?
tracking-fennec: ? → -
There's one crash in 17.0 Beta: bp-c3ce7c33-8593-4cde-9df1-92a072121113.
Crash Signature: with a size of 7 at android.database.AbstractCursor.checkPosition(AbstractCursor.java) ] → with a size of 7 at android.database.AbstractCursor.checkPosition(AbstractCursor.java) ] [@ android.database.CursorIndexOutOfBoundsException: Index 0 requested, with a size of 0 at android.database.AbstractCursor.checkPosition(AbstractCursor.java)]
Summary: android.database.CursorIndexOutOfBoundsException: Index -1 requested, with a size of <n> at android.database.AbstractCursor.checkPosition(AbstractCursor.java) → android.database.CursorIndexOutOfBoundsException: Index <m> requested, with a size of <n> at android.database.AbstractCursor.checkPosition(AbstractCursor.java)
Version: Trunk → Firefox 17
Assignee: lucasr.at.mozilla → nobody
Crash Signature: , with a size of 7 at android.database.AbstractCursor.checkPosition(AbstractCursor.java) ] [@ android.database.CursorIndexOutOfBoundsException: Index 0 requested, with a size of 0 at android.database.AbstractCursor.checkPosition(AbstractCursor.java)] → , with a size of 7 at android.database.AbstractCursor.checkPosition(AbstractCursor.java) ] [@ android.database.CursorIndexOutOfBoundsException: Index 0 requested, with a size of 0 at android.database.AbstractCursor.checkPosition(AbstractCursor.java)] [@…
Closing because no crashes reported for 12 weeks.
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.