Last Comment Bug 720559 - IonMonkey: Cannot compile functions with JSOP_THIS using OSR.
: IonMonkey: Cannot compile functions with JSOP_THIS using OSR.
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: David Anderson [:dvander]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-23 16:13 PST by Sean Stangl [:sstangl]
Modified: 2012-02-01 11:22 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Test case. (271 bytes, application/javascript)
2012-01-23 16:13 PST, Sean Stangl [:sstangl]
no flags Details
fix (1.34 KB, patch)
2012-01-27 19:29 PST, David Anderson [:dvander]
jdemooij: review+
Details | Diff | Review

Description Sean Stangl [:sstangl] 2012-01-23 16:13:59 PST
Created attachment 590924 [details]
Test case.

IonBuilder::jsop_this() fails compilation if thisParam is not of type Object, but in the case of OSR, the parameter is a Value-typed MPhi. This hurts us on several benchmarks, notably access-nbody.
Comment 1 David Anderson [:dvander] 2012-01-27 19:29:10 PST
Created attachment 592355 [details] [diff] [review]
fix

The problem is that we don't type phis until type analysis - more evidence that, even when it's safe, we shouldn't rely on MIR types during building. This is a quick fix that I think is correct: just query the initial type from TI.

(This brings our kraken-ai-astar score from 14000ms to 263, close to crankshaft - more work needed to get to -m -n speed.)
Comment 2 David Anderson [:dvander] 2012-02-01 11:22:29 PST
http://hg.mozilla.org/projects/ionmonkey/rev/b61f059b9db3

Note You need to log in before you can comment on or make changes to this bug.