Mozilla allows CSS controls to overwrite parts of the window.

RESOLVED DUPLICATE of bug 5195

Status

()

--
major
RESOLVED DUPLICATE of bug 5195
18 years ago
18 years ago

People

(Reporter: dylang, Assigned: pierre)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
On the page I have in the URL box, I have an example article with some CSS and a
floating menu box.  I've played with the width, and produced a box which covers
the scrollbar of Mozilla build 2001031208 at a res of 1152x864.  I really don't
think CSS should be able to overwrite parts of the browser frame -- it's too
easy to spoof controls that lead to goatse.cx :)
I cannot reproduce this with the new viewmanager.  I _do_ see this with the old
viewmanager.  Marking duplicate of "Fixed positioned elements drawing overtop of
scrollbars [FIX POS]".

Dylan, to try out the new viewmanager (which should be on by default within
days), add

 user_pref("nglayout.debug.enable_scary_view_manager", true);

to your prefs.js file.  It fixes many bugs related to fixed positioning.

*** This bug has been marked as a duplicate of 5195 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.