Last Comment Bug 720688 - Add the ability to strip MAR signatures
: Add the ability to strip MAR signatures
Status: VERIFIED FIXED
[qa-]
:
Product: Toolkit
Classification: Components
Component: Application Update (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: mozilla12
Assigned To: Brian R. Bondy [:bbondy]
:
Mentors:
Depends on: 699700 708688 708690 708697 728935
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-24 06:42 PST by Brian R. Bondy [:bbondy]
Modified: 2012-03-29 17:02 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
fixed
fixed


Attachments
Ability to strip MAR signatures. Patch v1. (15.34 KB, patch)
2012-01-24 09:08 PST, Brian R. Bondy [:bbondy]
no flags Details | Diff | Splinter Review
Ability to strip MAR signatures. Patch v2. (14.82 KB, patch)
2012-01-31 12:24 PST, Brian R. Bondy [:bbondy]
no flags Details | Diff | Splinter Review
Ability to strip MAR signatures. Patch v3. (15.46 KB, patch)
2012-02-02 16:14 PST, Brian R. Bondy [:bbondy]
robert.strong.bugs: review+
Details | Diff | Splinter Review

Description Brian R. Bondy [:bbondy] 2012-01-24 06:42:43 PST
Add a new command line argument to the mar program to strip the MAR signature block from a MAR file.  This can be used to repurpose a MAR with a new product information block.  

Also add a command line to override the product information block defaults with specific values.
Comment 1 Brian R. Bondy [:bbondy] 2012-01-24 09:08:01 PST
Created attachment 591123 [details] [diff] [review]
Ability to strip MAR signatures. Patch v1.
Comment 2 Brian R. Bondy [:bbondy] 2012-01-24 09:08:32 PST
This first patch is for the ability to strip MAR signatures only.

I'll have another patch for the ability to refresh a product information block with new values.
Comment 3 Brian R. Bondy [:bbondy] 2012-01-31 12:24:55 PST
Created attachment 593181 [details] [diff] [review]
Ability to strip MAR signatures. Patch v2.

Rebased because of added -T option from dependent patch.
Comment 4 Brian R. Bondy [:bbondy] 2012-02-02 16:14:34 PST
Created attachment 594005 [details] [diff] [review]
Ability to strip MAR signatures. Patch v3.

- Accidentally removed '-r' condition to break out of loop in patch v2. Fixed.
Comment 5 Robert Strong [:rstrong] (use needinfo to contact me) 2012-02-08 23:41:24 PST
Comment on attachment 594005 [details] [diff] [review]
Ability to strip MAR signatures. Patch v3.

Looks good but I didn't dive too deeply into this patch
Comment 6 Brian R. Bondy [:bbondy] 2012-02-24 13:41:11 PST
http://hg.mozilla.org/mozilla-central/rev/ad8fe9d36d16
Comment 7 Brian R. Bondy [:bbondy] 2012-02-29 18:23:07 PST
http://hg.mozilla.org/releases/mozilla-aurora/rev/18840d884c97
Comment 8 Brian R. Bondy [:bbondy] 2012-03-29 17:02:35 PDT
I've used this a lot for repairing various MARs, marking as verified.

Note You need to log in before you can comment on or make changes to this bug.