Debug intent doesn't extract libs with new linker

RESOLVED FIXED in Firefox 11

Status

()

Firefox for Android
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

unspecified
Firefox 12
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox11 fixed)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Updated

5 years ago
Summary: Debug intent doesn't extract libs → Debug intent doesn't extract libs with new linker
(Assignee)

Comment 1

5 years ago
Created attachment 591145 [details] [diff] [review]
Set MOZ_LINKER_CACHE instead of CACHE_PATH
Attachment #591145 - Flags: review?(blassey.bugs)
Attachment #591145 - Flags: review?(blassey.bugs) → review+
(Assignee)

Comment 2

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/4034e454bfbb
Whiteboard: [inbound]
https://hg.mozilla.org/mozilla-central/rev/4034e454bfbb
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → Firefox 12
(Assignee)

Comment 4

5 years ago
Comment on attachment 591145 [details] [diff] [review]
Set MOZ_LINKER_CACHE instead of CACHE_PATH

[Approval Request Comment]
Regression caused by bug 683127
This only really affects running under valgrind and maybe oprofile. gdb works fine without extracting libs. Running under valgrind will be required for binary reordering, that we'll probably do more or less manually on firefox 11.
Attachment #591145 - Flags: approval-mozilla-aurora?

Comment 5

5 years ago
Comment on attachment 591145 [details] [diff] [review]
Set MOZ_LINKER_CACHE instead of CACHE_PATH

[Triage Comment]
Mobile only - approved for Aurora.
Attachment #591145 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 6

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/dc0eca03f981
status-firefox11: --- → fixed
You need to log in before you can comment on or make changes to this bug.