Last Comment Bug 720759 - Windows warning patrol
: Windows warning patrol
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All Windows 7
: -- minor (vote)
: mozilla12
Assigned To: Jeff Walden [:Waldo] (remove +bmo to email)
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-24 10:37 PST by Jeff Walden [:Waldo] (remove +bmo to email)
Modified: 2012-01-25 07:26 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
The guard object classes need to be exported, if they're going to be used in exported APIs (929 bytes, patch)
2012-01-24 10:39 PST, Jeff Walden [:Waldo] (remove +bmo to email)
Ms2ger: review+
Details | Diff | Splinter Review
Change a mess of function signatures to take bool*, not JSBool*, all to fix one Windows warning comparing bool to JSBool (16.03 KB, patch)
2012-01-24 10:41 PST, Jeff Walden [:Waldo] (remove +bmo to email)
Ms2ger: review+
Details | Diff | Splinter Review
Delete EqualStrings(cx, linearStr1, linearStr2, &equal) so everyone has to use the made-for-linear-strings overload (788 bytes, patch)
2012-01-24 10:44 PST, Jeff Walden [:Waldo] (remove +bmo to email)
Ms2ger: review+
Details | Diff | Splinter Review

Description Jeff Walden [:Waldo] (remove +bmo to email) 2012-01-24 10:37:47 PST
!summon themaid
Comment 1 Jeff Walden [:Waldo] (remove +bmo to email) 2012-01-24 10:39:29 PST
Created attachment 591170 [details] [diff] [review]
The guard object classes need to be exported, if they're going to be used in exported APIs

From the log for js/src/jsutil.h:

user:        Jeff Walden <jwalden@mit.edu>
date:        Wed Oct 05 15:21:53 2011 -0700
summary:     Make the guard-object macros, used to ensure a class can't accidentally be constructed only temporarily, JS_FRIEND_API-compatible, since they're being used in friend declarations now.  rs=cdleary/luke, no bug

Gotta do the same thing for mfbt's classes...
Comment 2 Jeff Walden [:Waldo] (remove +bmo to email) 2012-01-24 10:41:10 PST
Created attachment 591173 [details] [diff] [review]
Change a mess of function signatures to take bool*, not JSBool*, all to fix one Windows warning comparing bool to JSBool

First it was one method, then two, then then then.  I drew the line at changing js_TestXMLEquality.  And I think changing JSEqualityOp's not possible now either.  :-\
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2012-01-24 10:43:00 PST
Comment on attachment 591170 [details] [diff] [review]
The guard object classes need to be exported, if they're going to be used in exported APIs

Review of attachment 591170 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm
Comment 4 Jeff Walden [:Waldo] (remove +bmo to email) 2012-01-24 10:44:16 PST
Created attachment 591176 [details] [diff] [review]
Delete EqualStrings(cx, linearStr1, linearStr2, &equal) so everyone has to use the made-for-linear-strings overload

Yes, Virginia, MOZ_DELETE works outside of classes too.
Comment 5 :Ms2ger (⌚ UTC+1/+2) 2012-01-24 10:46:34 PST
Comment on attachment 591173 [details] [diff] [review]
Change a mess of function signatures to take bool*, not JSBool*, all to fix one Windows warning comparing bool to JSBool

Review of attachment 591173 [details] [diff] [review]:
-----------------------------------------------------------------

I like.
Comment 6 :Ms2ger (⌚ UTC+1/+2) 2012-01-24 10:48:46 PST
Comment on attachment 591176 [details] [diff] [review]
Delete EqualStrings(cx, linearStr1, linearStr2, &equal) so everyone has to use the made-for-linear-strings overload

Review of attachment 591176 [details] [diff] [review]:
-----------------------------------------------------------------

Sure, if this works.
Comment 8 Ed Morley [:emorley] 2012-01-24 13:11:45 PST
Backed out for win debug failures: (coalescing means this is the first tbpl push that shopws the failure)
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=b7f926cfa8c8
https://tbpl.mozilla.org/php/getParsedLog.php?id=8796111&tree=Mozilla-Inbound

https://hg.mozilla.org/integration/mozilla-inbound/rev/cac3f64d36d0
Comment 9 Jeff Walden [:Waldo] (remove +bmo to email) 2012-01-24 14:39:32 PST
Sigh; I wasn't thinking that JS_FRIEND_API expands to an export or an import depending on the user.  I needed MFBT_API instead.  Relanded with that, after doing a Windows debug build with that to verify the fix.

https://hg.mozilla.org/integration/mozilla-inbound/rev/ec9a6b8c81d8
https://hg.mozilla.org/integration/mozilla-inbound/rev/5d572733c31e
https://hg.mozilla.org/integration/mozilla-inbound/rev/fd742da19c52

Note You need to log in before you can comment on or make changes to this bug.