Closed Bug 720764 Opened 8 years ago Closed 8 years ago

Show toast alert for opening a new tab in the background from the Awesomescreen

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 13
Tracking Status
firefox11 --- verified
firefox12 --- verified
firefox13 --- verified
fennec + ---

People

(Reporter: aaronmt, Assigned: lucasr)

Details

(Keywords: late-l10n, Whiteboard: tabs-ux)

Attachments

(1 file)

Currently when you open a new tab in the background from the Awesomescreen there is no toast alert notification akin to how you see it through traditional tab opening means in web content.

--
Samsung Galaxy Nexus (Android 4.0.3)
Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20120124 Firefox/12.0a1 Fennec/12.0a1
Whiteboard: tab-ux
Whiteboard: tab-ux → tabs-ux
tracking-fennec: --- → +
Assignee: nobody → lucasr.at.mozilla
Isn't there already a property or string entity in the toast for when you open a new tab via context menu in web-content: 'New tab opened'?
(In reply to Aaron Train [:aaronmt] from comment #2)
> Isn't there already a property or string entity in the toast for when you
> open a new tab via context menu in web-content: 'New tab opened'?

No, the existing one is on the gecko side.
Technically, I don't see the tab being opened in the background. It's just behind the Awesomebar. It still becomes the selected tab. Is this the intent of the feature?
Comment on attachment 593119 [details] [diff] [review]
Show toast notification when opening link in a new tab in awesomebar

Since this is not truly a background tab, we can't handle this in Gecko, where I hoped to put the code. We really do need to do this in Java.
Attachment #593119 - Flags: review?(mark.finkle) → review+
Comment on attachment 593119 [details] [diff] [review]
Show toast notification when opening link in a new tab in awesomebar

Important polish fix. Feedback when opening a URL in a new tab from awesome screen. Non-risk. Adds one string though.
Attachment #593119 - Flags: approval-mozilla-aurora?
Comment on attachment 593119 [details] [diff] [review]
Show toast notification when opening link in a new tab in awesomebar

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #593119 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/d170e6c4ce3e
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 13
Comment on attachment 593119 [details] [diff] [review]
Show toast notification when opening link in a new tab in awesomebar

[Triage Comment]
Mobile only - approved for Aurora 12 and Beta 11.
Attachment #593119 - Flags: approval-mozilla-beta?
Attachment #593119 - Flags: approval-mozilla-beta+
Attachment #593119 - Flags: approval-mozilla-aurora?
Attachment #593119 - Flags: approval-mozilla-aurora+
This broke string freeze, just like so. Lucas, fill out the form when you request approval. Alex, if someone doesn't fill out the form, just don't grant approval, please?
Keywords: late-l10n
Nightly 13.0a1 (2012-02-06)
Aurora 12.0a2 (2012-02-07)
Beta 11.0 (20120206202409 - http://hg.mozilla.org/releases/mozilla-beta/rev/1c0aba74d116)
Device: Samsung Google Nexus S - Android 2.3.6
You need to log in before you can comment on or make changes to this bug.