Closed Bug 72077 Opened 20 years ago Closed 19 years ago

failure to resolve either ipv6 hostname or ipv6 address

Categories

(Core :: Networking, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Future

People

(Reporter: steven.ayer, Assigned: neeti)

References

()

Details

according to chris blizzard (blizzard@mozilla.org), this is a bug.
Could you please provide some more information?

1)  What's an example of an actual address we fail to resolve?
2)  If it's a hostname, does that hostname have a IPv4 address associated with
it as well?
Comments from reporter:

1) an entry in /etc/hosts, thus:

::1 localhost6

actually, there's another:

fec0::1234   ayerlaptop  

this one is the localhost's site-local address.  btw, we have talked to
this machine using telnet and ping using these ipv6 hostname mappings.

2) no, when we place an ipv4 address in the hosts table, then it
works.  but that's not what this bug is about!

thanks for your help,
steve ayer
Perhaps I wasn't clear.  What are you typing in the browser's location bar?
Comments from reporter in email:

whether i type localhost6 or ::1, ayerlaptop or fec0::1234 in the location
bar, it bombs as described earlier.

this means that it can't handle an ipv6 address, or map an ipv6 address
listed in /etc/hosts.

so, in summary, the following locations, valid ipv6 addresses all to this
machine, fail:

http://::1
http://localhost6
http://ayerlaptop
http://fec0::1234
http://::1 and http://fec0::1234 are invalid.  According to RFC 2732 (Format for
Literal IPv6 Addresses in URL's), those should be written as:

http://[::1] and http://[fec0::1234]

Could you let us know whether this fixes your problem with the literal IPs? 
Also, if you would not mind, could you attach a complete copy of your /etc/hosts
file?

Thanks for you patience.
no, encapsulating ipv6 literal addresses in [] does not work.

as for the entire /etc/hosts, the entire contents that are currently uncommented
are listed below, but for your edification:

127.0.0.1  localhost

::1  localhost6
fec0::1234 ayerlaptop
Marking new, since presumably Steven has tested that IPv6 is properly enabled in
the kernel and works in other applications that are IPv6-aware.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → mozilla1.0
Relieving tever of IPv6 related QA.
QA Contact: tever → benc
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1
Target Milestone: mozilla1.0.1 → Future
Using Mozilla-1.0 under linux I can get this URL to work:

http://[3ffe:b00:c18:1::10]/

The hompage is downloaded using IPv6 over the 6bone.
I've tried all this on my machine and I think that if this was a problem it has
been fixed. If steven.ayer@compaq.com is still having this problem with 1.0, let
me know and I'll check it out.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.