Last Comment Bug 720795 - Screen orientation API reading and event implementation in Android
: Screen orientation API reading and event implementation in Android
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
Depends on: 737392
Blocks: 720794
  Show dependency treegraph
 
Reported: 2012-01-24 12:26 PST by Mounir Lamouri (:mounir)
Modified: 2012-03-21 03:52 PDT (History)
6 users (show)
mounir: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (31.86 KB, patch)
2012-01-24 12:26 PST, Mounir Lamouri (:mounir)
dougt: review+
mounir: checkin+
Details | Diff | Review

Description Mounir Lamouri (:mounir) 2012-01-24 12:26:29 PST
Created attachment 591218 [details] [diff] [review]
Patch
Comment 1 Doug Turner (:dougt) 2012-01-30 16:05:56 PST
Comment on attachment 591218 [details] [diff] [review]
Patch

Review of attachment 591218 [details] [diff] [review]:
-----------------------------------------------------------------

::: embedding/android/GeckoScreenOrientationListener.java
@@ +106,5 @@
> +      mOrientation = eScreenOrientation_LandscapeSecondary;
> +    } else if (rotation == Surface.ROTATION_90) {
> +      mOrientation = eScreenOrientation_LandscapePrimary;
> +    } else {
> +      Log.e("GeckoScreenOrientationListener", "Unexpected value received! (" + rotation + ")");

i think you just should return early
Comment 2 Mounir Lamouri (:mounir) 2012-02-09 02:38:49 PST
Comment on attachment 591218 [details] [diff] [review]
Patch

Pushed with the early return.
Comment 3 Ed Morley [:emorley] 2012-02-09 04:09:40 PST
Backed out of inbound for build failures on all platforms:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=4a763183482f

https://hg.mozilla.org/integration/mozilla-inbound/rev/c4c7eaaeec91
Comment 4 Ed Morley [:emorley] 2012-02-09 08:46:15 PST
Relanded, but the push had to be backed out again for bustage:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=1ca8d5a931ac

https://hg.mozilla.org/integration/mozilla-inbound/rev/33ffd55f2dfe

Please can this/the rest of the push be run on try before landing a third time :-)
Comment 5 Phil Ringnalda (:philor) 2012-03-17 17:14:26 PDT
https://hg.mozilla.org/mozilla-central/rev/aa978ffa44bc so it must have been :)
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2012-03-17 19:00:59 PDT
I backed this out along with all the other patches in the initial push. Something in the push regressed Ts on Android by 20% and I don't know which patch is to blame:

https://hg.mozilla.org/mozilla-central/rev/e94edfdb1f5b

Regression Ts increase 20.6% on Android 2.2 Mozilla-Inbound
--------------------------------------------------------------
    Previous: avg 2653.656 stddev 87.856 of 30 runs up to revision 1239bd0779a6
    New     : avg 3201.178 stddev 110.202 of 5 runs since revision 0d61a0d8dba4
    Change  : +547.522 (20.6% / z=6.232)
    Graph   : http://mzl.la/zD3EWy
Comment 7 Mounir Lamouri (:mounir) 2012-03-21 03:52:17 PDT
https://hg.mozilla.org/mozilla-central/rev/7bcf75d570a8

Note You need to log in before you can comment on or make changes to this bug.