Last Comment Bug 720811 - this._activeCall is null is the call has not been answered
: this._activeCall is null is the call has not been answered
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla12
Assigned To: Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
:
Mentors:
: 721266 (view as bug list)
Depends on:
Blocks: b2g-telephony
  Show dependency treegraph
 
Reported: 2012-01-24 12:56 PST by Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
Modified: 2012-01-26 15:06 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Check if this._activeCall is not null (1.09 KB, patch)
2012-01-24 12:56 PST, Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
philipp: review+
Details | Diff | Splinter Review

Description Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2012-01-24 12:56:20 PST
Created attachment 591233 [details] [diff] [review]
Check if this._activeCall is not null

If the call has not been answered this._activeCall is never set and this fire in error in the disconnect handler that messed up Gaia's UI.
Comment 1 Philipp von Weitershausen [:philikon] 2012-01-24 13:04:47 PST
Comment on attachment 591233 [details] [diff] [review]
Check if this._activeCall is not null

Makes sense. r=philikon
Comment 2 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2012-01-24 13:26:11 PST
http://hg.mozilla.org/integration/mozilla-inbound/rev/5ab431949952
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2012-01-25 07:22:21 PST
https://hg.mozilla.org/mozilla-central/rev/5ab431949952

No need for the [inbound], thanks
Comment 4 Philipp von Weitershausen [:philikon] 2012-01-26 15:06:20 PST
*** Bug 721266 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.