Last Comment Bug 720837 - use a different wordmark and possibly other branding changes for Firefox 10 ESR
: use a different wordmark and possibly other branding changes for Firefox 10 ESR
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: :Gavin Sharp [email: gavin@gavinsharp.com]
:
Mentors:
Depends on: 721538
Blocks: 717106 811935
  Show dependency treegraph
 
Reported: 2012-01-24 14:09 PST by Ben Hearsum (:bhearsum)
Modified: 2012-11-14 15:18 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch for new wordmark image (7.05 KB, patch)
2012-01-26 15:57 PST, :Gavin Sharp [email: gavin@gavinsharp.com]
bhearsum: checkin+
Details | Diff | Splinter Review
screenshot of new wordmark in dialog (126.30 KB, image/png)
2012-01-26 15:59 PST, :Gavin Sharp [email: gavin@gavinsharp.com]
no flags Details

Description Ben Hearsum (:bhearsum) 2012-01-24 14:09:41 PST
bug 717106 talks about using a different wordmark for the upcoming ESR release, and possibly other branding changes like the display name. We need to put these changes somewhere and make sure the release uses them.

If we use a separate branding directory it would be great to update the release mozconfigs to set it properly when MOZ_UPDATE_CHANNEL is esr. browser/config/mozconfigs{linux32,linux64,macosx64,win32}/release are the files in question.
Comment 1 Mardeg 2012-01-24 14:22:17 PST
What obstacles prevent a wordmark being in SVG format instead of PNG?
Comment 2 Ben Hearsum (:bhearsum) 2012-01-24 14:24:34 PST
(In reply to Mardeg from comment #1)
> What obstacles prevent a wordmark being in SVG format instead of PNG?

I suggest tracking this elsewhere. This bug is specifically about branding changes for the ESR, and needs to be completed in short order.
Comment 3 Laura Mesa [:lmesa] [:lvmesa] 2012-01-24 14:27:10 PST
Here is the wordmark as a PNG: https://bugzilla.mozilla.org/attachment.cgi?id=591271&action=edit
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-01-25 14:17:54 PST
So the only difference we want between this build and Firefox 10 is the different wordmark in the about dialog?
Comment 5 Ben Hearsum (:bhearsum) 2012-01-25 14:20:38 PST
I think Laura and/or Kev want something in the title bar, too. I'm not 100% sure about that though.
Comment 6 Laura Mesa [:lmesa] [:lvmesa] 2012-01-25 14:33:41 PST
(In reply to Ben Hearsum [:bhearsum] from comment #5)
> I think Laura and/or Kev want something in the title bar, too. I'm not 100%
> sure about that though.

1)we want to change the wordmark in the about:dialogue. 
2) Update the dialogue so it says "You are currently on the Firefox ESR update channel"
3) Update the description in the about dialogue to say: 
"Firefox ESR is intended for groups who deploy and maintain the desktop environment in large organizations such as universities and other schools, county or city governments and businesses."
4) I want to make sure when people install the ESR, when it shows up on their desktop or applications that its says Firefox ESR and not just Firefox. 
5) Update the Title bar to say "Firefox ESR"

If needed we can make more cosmetic changes in the next dot release.
Comment 7 Ben Hearsum (:bhearsum) 2012-01-25 14:36:38 PST
(In reply to Laura Mesa [:lmesa] [:lvmesa] from comment #6)
> 2) Update the dialogue so it says "You are currently on the Firefox ESR
> update channel"

Is it OK for this to be "You are currently on the esr update channel"?
Comment 8 Laura Mesa [:lmesa] [:lvmesa] 2012-01-25 14:39:04 PST
(In reply to Ben Hearsum [:bhearsum] from comment #7)
> (In reply to Laura Mesa [:lmesa] [:lvmesa] from comment #6)
> > 2) Update the dialogue so it says "You are currently on the Firefox ESR
> > update channel"
> 
> Is it OK for this to be "You are currently on the esr update channel"?

If we do it "ESR" as opposed to "esr" I'm ok with it.
Comment 9 Ben Hearsum (:bhearsum) 2012-01-25 14:39:52 PST
(In reply to Laura Mesa [:lmesa] [:lvmesa] from comment #8)
> (In reply to Ben Hearsum [:bhearsum] from comment #7)
> > (In reply to Laura Mesa [:lmesa] [:lvmesa] from comment #6)
> > > 2) Update the dialogue so it says "You are currently on the Firefox ESR
> > > update channel"
> > 
> > Is it OK for this to be "You are currently on the esr update channel"?
> 
> If we do it "ESR" as opposed to "esr" I'm ok with it.

OK, should be fine, and simpler than the original form.
Comment 10 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-01-26 13:11:45 PST
(In reply to Laura Mesa [:lmesa] [:lvmesa] from comment #6)
> 1)we want to change the wordmark in the about:dialogue. 
> 2) Update the dialogue so it says "You are currently on the Firefox ESR
> update channel"

These are doable (the channel will be just "ESR" though, as bhearsum notes).

> 3) Update the description in the about dialogue to say: 
> "Firefox ESR is intended for groups who deploy and maintain the desktop
> environment in large organizations such as universities and other schools,
> county or city governments and businesses."

We can't add this kind of string to the about dialog on a weeks notice - this will need to bubble up through the normal channels for proper l10n.

> 4) I want to make sure when people install the ESR, when it shows up on their
> desktop or applications that its says Firefox ESR and not just Firefox.
> 5) Update the Title bar to say "Firefox ESR"

The only simple way to achieve these is by changing "Firefox" to "Firefox ESR" globally across the app. All references to "Firefox" in the UI would be changed to "Firefox ESR".
Comment 11 Axel Hecht [:Pike] 2012-01-26 13:21:20 PST
PS: "through the channels" probably implies that this goes with ESR 16 or whichever that version is going to be, and not 10.x. What comes through the channels is bound to a gecko/firefox version 11+
Comment 12 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-01-26 14:01:25 PST
Laura: We need a version of https://bugzilla.mozilla.org/attachment.cgi?id=591271&action=edit that roughly matches http://mxr.mozilla.org/mozilla-central/source/browser/branding/official/content/about-wordmark.png (i.e. without the included logo). Should I file another marketing::design bug?
Comment 13 Laura Mesa [:lmesa] [:lvmesa] 2012-01-26 14:23:04 PST
(In reply to Gavin Sharp (use gavin@gavinsharp.com for email) from comment #12)
> Laura: We need a version of
> https://bugzilla.mozilla.org/attachment.cgi?id=591271&action=edit that
> roughly matches
> http://mxr.mozilla.org/mozilla-central/source/browser/branding/official/
> content/about-wordmark.png (i.e. without the included logo). Should I file
> another marketing::design bug?

I think that would be best. CC me and I'll get it to the right designer for a quick turn-around.
Comment 14 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-01-26 15:57:52 PST
Created attachment 591983 [details] [diff] [review]
patch for new wordmark image
Comment 15 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-01-26 15:59:31 PST
Created attachment 591985 [details]
screenshot of new wordmark in dialog
Comment 16 Ben Hearsum (:bhearsum) 2012-01-26 17:49:56 PST
(In reply to Ben Hearsum [:bhearsum] from comment #9)
> (In reply to Laura Mesa [:lmesa] [:lvmesa] from comment #8)
> > (In reply to Ben Hearsum [:bhearsum] from comment #7)
> > > (In reply to Laura Mesa [:lmesa] [:lvmesa] from comment #6)
> > > > 2) Update the dialogue so it says "You are currently on the Firefox ESR
> > > > update channel"
> > > 
> > > Is it OK for this to be "You are currently on the esr update channel"?
> > 
> > If we do it "ESR" as opposed to "esr" I'm ok with it.
> 
> OK, should be fine, and simpler than the original form.

Unfortunately, it looks like the build system forcibly lower cases the channel name, so this doesn't work =(. Gavin, any idea if we can make this change some other way, or are we stuck?
Comment 17 Mark Banner (:standard8) (afk until 26th July) 2012-01-27 01:44:07 PST
(In reply to Gavin Sharp (use gavin@gavinsharp.com for email) from comment #10)
> > 4) I want to make sure when people install the ESR, when it shows up on their
> > desktop or applications that its says Firefox ESR and not just Firefox.
> > 5) Update the Title bar to say "Firefox ESR"
> 
> The only simple way to achieve these is by changing "Firefox" to "Firefox
> ESR" globally across the app. All references to "Firefox" in the UI would be
> changed to "Firefox ESR".

This does, of course, affect all dialogs and error pages, so you'll get things like "Firefox ESR is currently in offline mode".
Comment 18 Laura Mesa [:lmesa] [:lvmesa] 2012-01-27 08:59:02 PST
(In reply to Ben Hearsum [:bhearsum] from comment #16)
> (In reply to Ben Hearsum [:bhearsum] from comment #9)
> > (In reply to Laura Mesa [:lmesa] [:lvmesa] from comment #8)
> > > (In reply to Ben Hearsum [:bhearsum] from comment #7)
> > > > (In reply to Laura Mesa [:lmesa] [:lvmesa] from comment #6)
> > > > > 2) Update the dialogue so it says "You are currently on the Firefox ESR
> > > > > update channel"
> > > > 
> > > > Is it OK for this to be "You are currently on the esr update channel"?
> > > 
> > > If we do it "ESR" as opposed to "esr" I'm ok with it.
> > 
> > OK, should be fine, and simpler than the original form.
> 
> Unfortunately, it looks like the build system forcibly lower cases the
> channel name, so this doesn't work =(. Gavin, any idea if we can make this
> change some other way, or are we stuck?

:(. Oh well. If we can fix it great. If we can't until later, that's fine too. 


I spoke with Kev per comment 10 and he said he would comment yesterday with the final decision. As he has not, Kev, friendly ping.
Comment 19 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-01-27 12:46:24 PST
(In reply to Ben Hearsum [:bhearsum] from comment #16)
> Unfortunately, it looks like the build system forcibly lower cases the
> channel name, so this doesn't work =(. Gavin, any idea if we can make this
> change some other way, or are we stuck?

Don't think you should worry about it, not a big deal since update channel is kind of an implementation detail (none of the other possible values are user-friendlied in any way).
Comment 20 Ben Hearsum (:bhearsum) 2012-01-30 06:28:33 PST
http://hg.mozilla.org/releases/mozilla-esr10/rev/66745590c474
Comment 21 Ben Hearsum (:bhearsum) 2012-01-30 07:54:42 PST
The 32-bit Linux ESR build just finished and I confirmed that the wordmark is present in it, too. Thanks again for your help here Gavin.

Note You need to log in before you can comment on or make changes to this bug.