Last Comment Bug 720941 - Remove JSDOUBLE_COMPARE and content's equivalent DOUBLE_COMPARE
: Remove JSDOUBLE_COMPARE and content's equivalent DOUBLE_COMPARE
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- minor (vote)
: mozilla12
Assigned To: Jeff Walden [:Waldo] (remove +bmo to email)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-24 23:04 PST by Jeff Walden [:Waldo] (remove +bmo to email)
Modified: 2012-01-26 04:36 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (7.97 KB, patch)
2012-01-24 23:04 PST, Jeff Walden [:Waldo] (remove +bmo to email)
dmandelin: review+
Details | Diff | Review

Description Jeff Walden [:Waldo] (remove +bmo to email) 2012-01-24 23:04:57 PST
Created attachment 591373 [details] [diff] [review]
Patch

The implementation clearly indicates it was originally intended to work around some sort of Windows-only bug when it landed in 2004.  Whatever problem was being worked around also existed in 2006, when content/xslt/public/txDouble.h picked up a similar implementation. Six or eight years later, we don't even support anything before MSVC 2008 (obviously well after 2006), and tinderbox indicates it's no longer an issue (note that this is even the case with PGO builds, specifically enabled for the push).

https://tbpl.mozilla.org/?tree=Try&rev=f7cd9da8b89d

Let's get rid of these unnecessary, obfuscatory macros.
Comment 1 Boris Zbarsky [:bz] 2012-01-25 06:33:31 PST
> Six or eight years later, we don't even support anything before MSVC 2008

Tinderbox uses MSVC 2005.

But I'll believe we used something even older back in 2006... ;)
Comment 2 David Mandelin [:dmandelin] 2012-01-25 10:56:13 PST
(In reply to Jeff Walden (remove +bmo to email) from comment #0)
> Let's get rid of these unnecessary, obfuscatory macros.

Yes, let's. Especially if no rationale is given next to the macro definition: we either have to keep a weird thing forever that hardly any other software seems to need, or we can cut it out (and add it back in actually knowing why we need it on the off chance we actually do).
Comment 3 Jeff Walden [:Waldo] (remove +bmo to email) 2012-01-25 14:48:20 PST
Oh, right, MSVC 2008 != 8.  Stupid non-version version numbers.

https://hg.mozilla.org/integration/mozilla-inbound/rev/c1321dc798b7
Comment 4 Ed Morley [:emorley] 2012-01-26 04:36:28 PST
https://hg.mozilla.org/mozilla-central/rev/c1321dc798b7

Note You need to log in before you can comment on or make changes to this bug.