when closing browser window, frame disappears, flashes and then finally disappear

RESOLVED DUPLICATE of bug 145561

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 145561
17 years ago
16 years ago

People

(Reporter: achimha, Assigned: achimha)

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
This was introduced some weeks ago. I'm not sure whether this is a dup, could
not find anything.
Happens on OS/2 and on Win98 (confirmed by another user) so seems to be an
XP bug.

You can see this by closing a browser frame window. It will hide and then an
empty frame with with titlebar will reappear with the same size/position which
then completely disappears.

Comment 1

17 years ago
I occasionally see something like this on linux, often when closing a popup.
Another window of the same size pops up, and as soon as I place it disappears
along with the popup.

Comment 2

17 years ago
->danm
Assignee: trudelle → danm
(Assignee)

Updated

17 years ago
Assignee: danm → achimha
OS: other → OS/2
Hardware: Other → PC
(Assignee)

Comment 3

17 years ago
This is OS/2 specific, reassigning to me.
(Assignee)

Comment 4

17 years ago
Created attachment 30398 [details] [diff] [review]
don't show the window on each WM_FOCUSCHANGE, basically back out 1.37 change
(Assignee)

Updated

17 years ago
Depends on: 56770
(Assignee)

Comment 5

17 years ago
the patch has the problem of breaking 56770 again. We need WM_ACTIVATE as
well to get proper keyboard input focus. However, the original fix has the
problems mentioned. We might have to introduce some mIsBeingClosed flag to
nsWindow and set that in the XP code that does the window->Show(PR_FALSE)
before closing it. Any other suggestions?

Comment 6

16 years ago
This will be fixed by the focus checkin in 145561

*** This bug has been marked as a duplicate of 145561 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.