Calling preventDefault on the first touchmove event prevents panning, but not quickly enough

RESOLVED FIXED in Firefox 11

Status

()

Firefox for Android
General
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: wesj, Assigned: wesj)

Tracking

unspecified
Firefox 12
x86
Linux
Points:
---

Firefox Tracking Flags

(firefox11 fixed, firefox12 fixed, firefox13 fixed, fennec+)

Details

Attachments

(2 attachments)

(Assignee)

Description

6 years ago
See mbrubeck's test page:

http://limpet.net/w3/touchevents/preventDefault.html

panning on the prevent move box should not allow panning at all, but I believe that it will pan for a short distance and then stop. We have a bunch of timeout code designed to handle just this. Either the timeout is not long enough, or the code is not working correctly. I'm guessing its the later.

Updated

6 years ago
Blocks: 603008
tracking-fennec: --- → +
(Assignee)

Comment 1

6 years ago
Created attachment 592928 [details] [diff] [review]
Patch 1/2

Two parts to fix this. Luckily, they're small fixes now! I don't think I handled notifying correctly. Smaug, this works, but I'm not sure its correct. This ok?
Assignee: nobody → wjohnston
Attachment #592928 - Flags: review?(bugs)
(Assignee)

Comment 2

6 years ago
Created attachment 592930 [details] [diff] [review]
Patch 2/2

This was fallout from bad unbitrotting by me :( I lost some of the fixes for being notified if we had listeners in java. This restores them.
Attachment #592930 - Flags: review?(mark.finkle)
Attachment #592930 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 3

6 years ago
Part 2 inbound - http://hg.mozilla.org/integration/mozilla-inbound/rev/2fdade6a7582

Updated

6 years ago
Attachment #592928 - Attachment is patch: true

Updated

6 years ago
Attachment #592928 - Flags: review?(bugs) → review+

Comment 4

6 years ago
...assuming whoever listens for that notification does the right thing.

Comment 5

6 years ago
https://hg.mozilla.org/mozilla-central/rev/2fdade6a7582
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 12
(Assignee)

Comment 6

6 years ago
Comment on attachment 592928 [details] [diff] [review]
Patch 1/2

Regression caused by (bug #): 603008 multitouch
User impact if declined: Errors with multitouch events firing incorrectly
Testing completed (on m-c, etc.): landed on mc 1/2/2012
Risk to taking this patch (and alternatives if risky): Low risk. Should only affect builds with touch events enabled (i.e. mobile and b2g.
Attachment #592928 - Flags: approval-mozilla-beta?
Attachment #592928 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 7

6 years ago
Comment on attachment 592930 [details] [diff] [review]
Patch 2/2

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:

Regression caused by (bug #): 603008 multitouch
User impact if declined: Errors with multitouch events firing incorrectly
Testing completed (on m-c, etc.): landed on mc 1/2/2012
Risk to taking this patch (and alternatives if risky): Low risk. Should only affect builds with touch events enabled (i.e. mobile and b2g.
Attachment #592930 - Flags: approval-mozilla-beta?
Attachment #592930 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 8

6 years ago
Whoops. Forgot to list part 1:
http://hg.mozilla.org/mozilla-central/rev/69ca6e6c57ea
(Assignee)

Comment 9

6 years ago
Comment on attachment 592930 [details] [diff] [review]
Patch 2/2

This is already on Aurora.
Attachment #592930 - Flags: approval-mozilla-aurora?
Comment on attachment 592928 [details] [diff] [review]
Patch 1/2

[Triage Comment]
Mobile only - approved for Aurora 12 and Beta 11.
Attachment #592928 - Flags: approval-mozilla-beta?
Attachment #592928 - Flags: approval-mozilla-beta+
Attachment #592928 - Flags: approval-mozilla-aurora?
Attachment #592928 - Flags: approval-mozilla-aurora+
Comment on attachment 592930 [details] [diff] [review]
Patch 2/2

[Triage Comment]
Mobile only - approved for Aurora 12 and Beta 11.
Attachment #592930 - Flags: approval-mozilla-beta?
Attachment #592930 - Flags: approval-mozilla-beta+
Attachment #592930 - Flags: approval-mozilla-aurora+
part 1
https://hg.mozilla.org/releases/mozilla-aurora/rev/120652cab075

part 2 is already on aurora
status-firefox11: --- → affected
status-firefox12: --- → fixed
status-firefox13: --- → fixed
(Assignee)

Comment 13

6 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/07a6e25f6362
https://hg.mozilla.org/releases/mozilla-beta/rev/6e92cda6055a
status-firefox11: affected → fixed
You need to log in before you can comment on or make changes to this bug.