Last Comment Bug 721242 - After using Firefox migrator, the password manager sometimes can't decrypt passwords
: After using Firefox migrator, the password manager sometimes can't decrypt pa...
Status: VERIFIED FIXED
[qa!]
:
Product: Firefox
Classification: Client Software
Component: Migration (show other bugs)
: 12 Branch
: All All
: -- normal (vote)
: Firefox 13
Assigned To: Matthew N. [:MattN] (PM me if requests are blocking you)
:
: Matthew N. [:MattN] (PM me if requests are blocking you)
Mentors:
Depends on:
Blocks: 273874
  Show dependency treegraph
 
Reported: 2012-01-25 15:31 PST by Matthew N. [:MattN] (PM me if requests are blocking you)
Modified: 2012-03-20 03:30 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
v.1 delay the doStartup call (1.53 KB, patch)
2012-01-25 15:41 PST, Matthew N. [:MattN] (PM me if requests are blocking you)
mak77: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Matthew N. [:MattN] (PM me if requests are blocking you) 2012-01-25 15:31:04 PST
My theory is that PSM? is initialized before the key3.db file is copied to the destination profile.  Password manager outputs "Initializing key3.db with default blank password."

Mano wants to remove the ability to call DoStartup in bug 718586 so simply delaying the startup like was traditionally done in these situations would block that.
Comment 1 Matthew N. [:MattN] (PM me if requests are blocking you) 2012-01-25 15:41:08 PST
Created attachment 591641 [details] [diff] [review]
v.1 delay the doStartup call

I personally think we should take this patch for now to avoid having broken password migration on Mozilla 12.   We can address the removal of the startup argument in bug 718586 after branching so that there's more time to find a workaround to this problem, if necessary.
Comment 2 Matthew N. [:MattN] (PM me if requests are blocking you) 2012-02-17 12:55:00 PST
Comment on attachment 591641 [details] [diff] [review]
v.1 delay the doStartup call

Review ping
Comment 3 Marco Bonardo [::mak] 2012-02-20 06:26:34 PST
Comment on attachment 591641 [details] [diff] [review]
v.1 delay the doStartup call

Review of attachment 591641 [details] [diff] [review]:
-----------------------------------------------------------------

It's ok, for the sake of having this working in the 12-13 releases, though please add a comment explaning the problem in bug 718586 (if you didn't yet), so that it is somehow tracked for when that bug will be addressed.

and sigh, we really need to move on with making some tests :( As it is this may break at any time.

::: browser/components/migration/src/FirefoxProfileMigrator.js
@@ +233,5 @@
>  
>      if (aItems & MIGRATOR.PASSWORDS)
>        this._migratePasswords();
>  
> +    // The password manager encryption key must be copied before startup

nit: end with period
Comment 4 Matthew N. [:MattN] (PM me if requests are blocking you) 2012-02-23 19:30:47 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/18fda283b571
Comment 5 Marco Bonardo [::mak] 2012-02-24 02:45:36 PST
https://hg.mozilla.org/mozilla-central/rev/18fda283b571
Comment 6 Matthew N. [:MattN] (PM me if requests are blocking you) 2012-02-27 16:32:35 PST
Comment on attachment 591641 [details] [diff] [review]
v.1 delay the doStartup call

[Approval Request Comment]
Regression caused by (bug #): Not a regression, new code.
User impact if declined: password migration fails from an existing Firefox profile.  There is no UI to activate the feature in 12 but I will make an extension for SUMO to use.
Testing completed (on m-c, etc.): Tested on m-c for a few days.
Risk to taking this patch (and alternatives if risky): Low risk, trivial, tiny patch.
String changes made by this patch: None
Comment 7 Alex Keybl [:akeybl] 2012-03-01 11:22:06 PST
Comment on attachment 591641 [details] [diff] [review]
v.1 delay the doStartup call

[Triage Comment]
Low risk and fixes a regression in a new FF12 feature. Approving for Aurora.
Comment 8 Matthew N. [:MattN] (PM me if requests are blocking you) 2012-03-01 15:18:29 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/17f98701eca2
Comment 9 Ioana (away) 2012-03-20 03:30:26 PDT
Verified as fixed on:
Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20120318 Firefox/13.0a2
Mozilla/5.0 (X11; Linux i686; rv:13.0) Gecko/20120319 Firefox/13.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:13.0) Gecko/20120318 Firefox/13.0a2

Note You need to log in before you can comment on or make changes to this bug.