font.size.inflation.minTwips is set for XUL Fennec

RESOLVED FIXED in Firefox 12

Status

Fennec Graveyard
General
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: kbrosnan, Assigned: mbrubeck)

Tracking

Firefox 11
Firefox 12
ARM
Android

Details

(Whiteboard: readability)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
There is no UI to modify font.size.inflation.minTwips pref so it should be set to 0 on XUL Fennec.
(Assignee)

Updated

6 years ago
Assignee: nobody → mbrubeck
status-firefox10: --- → unaffected
status-firefox11: --- → affected
status-firefox12: --- → affected
Version: Trunk → Firefox 11
(Assignee)

Comment 1

6 years ago
Created attachment 591851 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): bug 627842

User impact if declined: XUL Fennec has font inflation enabled, which is largely untested there, has no UI for preferences, and interacts weirdly with XUL Fennec's existing text formatting option.

Testing completed (on m-c, etc.): Not yet landed on m-c.  We do not have active QA or community testing of XUL Fennec on m-c.  This needs to get into beta to get real testing.

Risk to taking this patch (and alternatives if risky): Very low risk. This is a low-risk, XUL-fennec-only patch that just flips a preference to disable a feature added in update 11.
Attachment #591851 - Flags: review?(mark.finkle)
Attachment #591851 - Flags: approval-mozilla-aurora?
Attachment #591851 - Flags: review?(mark.finkle)
Attachment #591851 - Flags: review+
Attachment #591851 - Flags: approval-mozilla-aurora?
Attachment #591851 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 2

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/f928b631a92d
Status: NEW → ASSIGNED
status-firefox12: affected → fixed
Target Milestone: --- → Firefox 12

Updated

6 years ago
Keywords: checkin-needed
(Assignee)

Comment 3

6 years ago
https://hg.mozilla.org/mozilla-central/rev/f928b631a92d
https://hg.mozilla.org/releases/mozilla-aurora/rev/d5db8b8f8c8a
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
status-firefox11: affected → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.