Style Editor auto-scroll to the selected style sheet is annoying

RESOLVED FIXED in Firefox 11

Status

()

Firefox
Developer Tools: Style Editor
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: cedricv, Assigned: cedricv)

Tracking

unspecified
Firefox 12
Points:
---

Firefox Tracking Flags

(firefox11 verified)

Details

(Whiteboard: [styleeditor][qa+][qa!:11])

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
The Style Editor should not scroll the list when the style sheet is selected because of a direct user click.

Updated

5 years ago
Whiteboard: [styleeditor] → [addToFirefox11][styleeditor]
(Assignee)

Comment 1

5 years ago
Created attachment 591758 [details] [diff] [review]
patch v1

It shouldn't be too hard to review.
Attachment #591758 - Flags: review?(paul)

Updated

5 years ago
Attachment #591758 - Flags: review?(paul) → review+

Updated

5 years ago
Whiteboard: [addToFirefox11][styleeditor] → [addToFirefox11][styleeditor][land-in-fx-team]

Comment 2

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/d5ceec63ef0a
Whiteboard: [addToFirefox11][styleeditor][land-in-fx-team] → [addToFirefox11][styleeditor][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/d5ceec63ef0a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [addToFirefox11][styleeditor][fixed-in-fx-team] → [addToFirefox11][styleeditor]
Target Milestone: --- → Firefox 12

Comment 4

5 years ago
Comment on attachment 591758 [details] [diff] [review]
patch v1

[Approval Request Comment]
Regression caused by (bug #): Not a regression, new feature.
User impact if declined: Bad user experience.
Testing completed (on m-c, etc.): on m-c.
Risk to taking this patch (and alternatives if risky): very very low. One JS line removed.
Attachment #591758 - Flags: approval-mozilla-aurora?

Comment 5

5 years ago
Comment on attachment 591758 [details] [diff] [review]
patch v1

[Triage Comment]
Low risk fix in support of a new feature. Approved for Aurora.
Attachment #591758 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 6

5 years ago
Created attachment 592664 [details] [diff] [review]
Patch v1 - rebased for Aurora

Comment 7

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/5bc8243d71ec
status-firefox11: --- → fixed
Whiteboard: [addToFirefox11][styleeditor] → [styleeditor]
Whiteboard: [styleeditor] → [styleeditor][qa+]

Comment 8

5 years ago
Verified using Firefox 11 beta 3 on Windows 7, Ubuntu 11.10 and Mac OS X 10.6.

Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0
Mozilla/5.0 (X11; Linux i686; rv:11.0) Gecko/20100101 Firefox/11.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0) Gecko/20100101 Firefox/11.0

The Style Editor does not scroll the list when the style sheet is selected by direct user click.
status-firefox11: fixed → verified
Whiteboard: [styleeditor][qa+] → [styleeditor][qa+][qa!:11]
You need to log in before you can comment on or make changes to this bug.