crash in GetContextFromObject @ CrashInJS

REOPENED
Unassigned

Status

()

Core
XPConnect
--
critical
REOPENED
6 years ago
6 years ago

People

(Reporter: rik, Unassigned)

Tracking

({crash})

12 Branch
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox12-)

Details

(crash signature)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-a8ce6fac-c354-43a2-a0dc-f54d22120127 .
============================================================= 
I got three crashes after installing about:jank.

I wasn't doing anything specific at the time and it's my first series of crash in a month.

Updated

6 years ago
Assignee: nobody → general
Component: Untriaged → JavaScript Engine
Depends on: 715713
Product: Firefox → Core
QA Contact: untriaged → general
Summary: crash CrashInJS → crash in GetContextFromObject @ CrashInJS

Comment 1

6 years ago
It might be related to bug 721025.
Assignee: general → nobody
Component: JavaScript Engine → XPConnect
QA Contact: general → xpconnect

Updated

6 years ago
Crash Signature: [@ CrashInJS] → [@ CrashInJS] [@ CrashInJS | GetContextFromObject]

Updated

6 years ago
Crash Signature: [@ CrashInJS] [@ CrashInJS | GetContextFromObject] → [@ CrashInJS] [@ CrashInJS | GetContextFromObject ]

Comment 2

6 years ago
https://crash-stats.mozilla.com/report/list?signature=CrashInJS%20%7C%20GetContextFromObject is topcrash #2 in Firefox 12.* in yesterday's data.

Comment 3

6 years ago
It's correlated to BExternal.dll:
  CrashInJS | GetContextFromObject|EXCEPTION_ACCESS_VIOLATION_WRITE (173 crashes)
    100% (173/173) vs.   7% (178/2475) BExternal.dll
Depends on: 715744
Keywords: topcrash
Version: Trunk → 12 Branch

Comment 4

6 years ago
We have no such crashes left yesterday on 12, I think we can call this fixed by the Babylon update and bug 715744. Agreed?

Comment 5

6 years ago
Sounds good to me. I will resolve as fixed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Resolution: FIXED → WORKSFORME

Comment 6

6 years ago
It's #3 top crasher in 12.0b2.

It's still correlated to BExternal.dll:
  CrashInJS | GetContextFromObject|EXCEPTION_ACCESS_VIOLATION_WRITE (914 crashes)
     99% (901/914) vs.   3% (901/26082) BExternal.dll
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Updated

6 years ago
tracking-firefox12: --- → ?

Comment 7

6 years ago
That Babylon guys were pretty responsive about bug 715744, can we reach out to them here as well Jorge?
tracking-firefox12: ? → +
I just sent a message to them.
Do we have a version number for that DLL? The newest versions of the Babylon software should have a versioned BExternal.dll.

Comment 10

6 years ago
(In reply to Jorge Villalobos [:jorgev] from comment #9)
> Do we have a version number for that DLL? The newest versions of the Babylon
> software should have a versioned BExternal.dll.
Amongst 26082 crashes with BExternal.dll loaded, there are no crashes with a versioned BExternal.dll.
According to Babylon, one of their affiliates was distributing the old DLL. The problem was corrected on their side, so the crash rate should diminish soon. If nothing has changed in a couple of days, please let me know and I'll ping them again.
(In reply to Jorge Villalobos [:jorgev] from comment #11)
> According to Babylon, one of their affiliates was distributing the old DLL.
> The problem was corrected on their side, so the crash rate should diminish
> soon. If nothing has changed in a couple of days, please let me know and
> I'll ping them again.

Thanks Jorge! We'll keep this bug on our radar.
(In reply to Scoobidiver from comment #10)
> (In reply to Jorge Villalobos [:jorgev] from comment #9)
> > Do we have a version number for that DLL? The newest versions of the Babylon
> > software should have a versioned BExternal.dll.
> Amongst 26082 crashes with BExternal.dll loaded, there are no crashes with a
> versioned BExternal.dll.

Actually given this, I don't believe there's any reason to continue tracking.
tracking-firefox12: + → -

Comment 14

6 years ago
It's #126 top browser crasher in 12.0b2 and #193 in 12.0b3, so no longer a top crasher.
Keywords: topcrash
So, it looks like this was caused by old versions of Babylon. Should this bug be closed then?
You need to log in before you can comment on or make changes to this bug.