Malicious "Plugin Video" Add-on

RESOLVED FIXED

Status

()

Toolkit
Blocklisting
RESOLVED FIXED
6 years ago
a year ago

People

(Reporter: MarkH, Assigned: jorgev)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 592070 [details]
20120126 content.zip

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.77 Safari/535.7

Steps to reproduce:

Downloaded http://123buzzbuzz.free[.]fr/content.xpi


Actual results:

Add-on name "Plugin Video"
Add-on homepage http://123buzzbuzz.free.fr

Addon contains youtube.js, which injects <script> to load http://123buzzbuzz.free.fr/g.js

g.js injects <script> to load http://123buzzbuzz.free.fr/yeah.js

yeah.js does the following
	steals the user's Facebook cookies / tokens
	grabs their friends list
	likes one of the following Facebook pages with ids "170270043065994","125634380874892","146184075465813","152559774839890","274266539251303","290925474288531","316272665054709"
	spams one from a set of text / bit.ly URL combos onto the user's wall
	all of the bit.ly URLs redirect to wholesale44.free.fr domain
	it then posts one of the same msg / URL pairs to the Facebook open graph


Expected results:

It should not steal cookies from the user's Facebook session and send messages to the user's friends without their consent.
(Assignee)

Comment 1

6 years ago
Id: youtube@youtube7.com
(Assignee)

Updated

6 years ago
Assignee: nobody → jorge
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 2

6 years ago
https://addons.mozilla.org/en-US/firefox/blocked/i55
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Duplicate of this bug: 721641
(Assignee)

Updated

5 years ago
Duplicate of this bug: 728487
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.