Last Comment Bug 721737 - Make sure that Makefiles needed for repacks are there for xulrunner firefox repacks.
: Make sure that Makefiles needed for repacks are there for xulrunner firefox r...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla13
Assigned To: Mike Hommey [:glandium]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-27 06:39 PST by Mike Hommey [:glandium]
Modified: 2012-02-17 05:45 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Building l10n for spellcheck and intl should happen from toolkit/ not $app/ (4.43 KB, patch)
2012-01-27 06:42 PST, Mike Hommey [:glandium]
l10n: review-
Details | Diff | Splinter Review
Add toolkit l10n Makefiles to browser/makefiles.sh (955 bytes, patch)
2012-02-09 23:48 PST, Mike Hommey [:glandium]
khuey: review+
l10n: feedback+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2012-01-27 06:39:22 PST
Currently, each application puts in $app/browser/Makefile.in snippets for l10n of spellcheck and intl, but both these directories are built from toolkit. In practice, this means that building a toolkit-only locale for use with e.g. xulrunner doesn't contain these.
Comment 1 Mike Hommey [:glandium] 2012-01-27 06:42:24 PST
Created attachment 592122 [details] [diff] [review]
Building l10n for spellcheck and intl should happen from toolkit/ not $app/

At the same time, don't build l10n for toolkit from browser/ when building against a libxul sdk. I didn't do the same for mobile and b2g because i doubt they build at all against a libxul sdk.
Comment 2 Axel Hecht [:Pike] 2012-01-27 06:53:36 PST
Comment on attachment 592122 [details] [diff] [review]
Building l10n for spellcheck and intl should happen from toolkit/ not $app/

I think this bug is WONTFIX. It's very much desired for mobile, for example, to make a call on whether spell checking by gecko is on, as it conflicts with the spellchecker on the device.

To be frank, I'm not sure why we're calling in to intl/locales, at all right now.

The LIBXUL_SDK doesn't convince me either, not sure why that would be?
Comment 3 Mike Hommey [:glandium] 2012-01-27 07:16:26 PST
(In reply to Axel Hecht [:Pike] from comment #2)
> Comment on attachment 592122 [details] [diff] [review]
> Building l10n for spellcheck and intl should happen from toolkit/ not $app/
> 
> I think this bug is WONTFIX. It's very much desired for mobile, for example,
> to make a call on whether spell checking by gecko is on, as it conflicts
> with the spellchecker on the device.

I don't see how that's related. A mobile build sets MOZ_SPELLCHECK in configure.in, and spellcheck l10n will be built from toolkit/locales, through the call from mobile/locales. IOW, nothing changes. Likewise for intl.

> The LIBXUL_SDK doesn't convince me either, not sure why that would be?

I build Firefox as a xulrunner application. As such, in the Firefox objdir, there is nothing under toolkit, because it's under the xulrunner objdir.
Comment 4 Axel Hecht [:Pike] 2012-01-27 07:25:14 PST
It's been a few years, I guess, but I recall that Benjamin wanted toolkit localization files to be part of the xulrunner-based applications and not xulrunner itself.
Comment 5 Mike Hommey [:glandium] 2012-01-27 07:30:07 PST
That's not possible, currently. xulrunner-based applications do not necessarily have the full source of xulrunner corresponding to the sdk they use to build, and the source is required to build l10n.
Comment 6 Axel Hecht [:Pike] 2012-02-05 09:53:42 PST
Talked to Mike IRL, given that the xulrunner part is hackery right now, we should just make sure that we have SUBMAKEFILES set up in browser and toolkit to not run into the build problem, and pack up all of toolkit as part of the firefox langpack.
Comment 7 Mike Hommey [:glandium] 2012-02-09 23:48:22 PST
Created attachment 595982 [details] [diff] [review]
Add toolkit l10n Makefiles to browser/makefiles.sh
Comment 8 Mike Hommey [:glandium] 2012-02-09 23:49:35 PST
Comment on attachment 595982 [details] [diff] [review]
Add toolkit l10n Makefiles to browser/makefiles.sh

Note we may want to make that depending on LIBXUL_SDK being defined.
Comment 9 Axel Hecht [:Pike] 2012-02-14 06:35:18 PST
Comment on attachment 595982 [details] [diff] [review]
Add toolkit l10n Makefiles to browser/makefiles.sh

Review of attachment 595982 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me. As this is the top-level firefox build foo, you probably want the real review from a peer of build.
Comment 11 Ed Morley [:emorley] 2012-02-17 05:45:12 PST
https://hg.mozilla.org/mozilla-central/rev/061557e27b59

Note You need to log in before you can comment on or make changes to this bug.