Firefox say incompatible even on compatible addon

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: Swarnava, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20120127])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Using Firefox 10 Beta 5, when i upgrading it to Firefox 10 beta 6, The IDM CC 7.3.11 saying its incompatible, but its compatible with 10.*, i saw this problem even when i upgrade from beta 4 to beta 5.
My Internet Download Manager version 6.08 Build 9 which is fully compatible with Firefox 10
(Reporter)

Updated

7 years ago
Whiteboard: [testday-20120127]
(Reporter)

Updated

7 years ago
Depends on: 711275
(Reporter)

Comment 1

7 years ago
Created attachment 592156 [details]
error
Confirming.

The problem is that in the ICM addon the ddl for Firefox 9 is incorrectly attempted to be loaded in Firefox 10:

binary-component components5/idmmzcc.dll appversion>=5.0a1 appversion<6.0a1

its an OR test, rather than AND, so this dll tries to load. Hence this error in the console: "Native module at path 'C:\Users\ej\AppData\Roaming\IDM\idmmzcc5\components5\idmmzcc.dll' is incompatible with this version of Firefox, has version 2, expected 10."

The Firefox update check detects this component and (rightly) realises that it won't work in Firefox 10 so alerts the user.

I can't see a good way to work around addons that are broken like this that wouldn't create other issues.
Blair, what do you think about this?

The correct component is loaded for 10, but then because of the unintuitive way manifest flags work, the same component for 5 is tried to be loaded and the incompatibility code kicks in. Would there be a way to detect these redundancies and ignore them? This would be a WONTFIX otherwise and the devs would need to figure out how to fix this in their manifest.

Comment 4

7 years ago
Please give me a link that documents manifest file rules. Specifically we need the current rules describing how to declare minimum and maximum version numbers of Firefox which are compatible with this binary component.

Thanks

Charles Jones
Software engineer
Tonec Inc. 
http://www.internetdownloadmanager.com
(In reply to Charles Jones from comment #4)
> Please give me a link that documents manifest file rules. Specifically we
> need the current rules describing how to declare minimum and maximum version
> numbers of Firefox which are compatible with this binary component.

As already mentioned, multiple flags are (unfortunately) combined using OR. The way around this is to use a sub-manfest. 

So in the chrome.manifest file, you'd have:
  manifest components-fx5.manifest appversion >=5.0a1

And a components-fx5.manifest file would contain:
binary-component components5/idmmzcc.dll appversion<6.0a1

See https://developer.mozilla.org/en/Chrome_Registration#manifest


However:
The Add-ons Manager doesn't currently use the flags when it's looking for binary-component lines to determine addon compatibility. That's bug 696701. So *any* binary-component line, regardless of it's flags, will make the addon use strict compatibility (determining compatibility based on exactly what's in install.rdf, or the compat info from AMO). You'll get a warning - but that's from the component manager, not the Add-ons Manager.

In other words, that binay-component line doesn't explain why the addon is being marked as incompatible.
If I understood correctly from the description, the add-on is only marked as incompatible in the update screen (while updating from 10b5 to 10b6). The Add-on Manager lists it correctly afterwards. 
 
If that is correct, then the issue described here is due to bug 711275. Which makes it invalid.

Any add-on which would be incompatible (with StrictCompatibility enabled) with 10 or 11 will be listed in the Software update screen. Initially, that should have only concerned add-ons until F 10, but with the workaround fix, includes add-ons incompatible with F11 too.

If my guess is correct, this should only occur when upgrading through betas. Upgrading from 9 release to 10 (using betates or releasetest channels) shouldn't list the add-on as incompatible.
Oh.... yes, that would make sense.

(In reply to Virgil Dicu [:virgil] [QA] from comment #6)
> If I understood correctly from the description, the add-on is only marked as
> incompatible in the update screen (while updating from 10b5 to 10b6). The
> Add-on Manager lists it correctly afterwards. 

Swarnava, can you confirm this?
(Reporter)

Comment 8

7 years ago
(In reply to Blair McBride (:Unfocused) from comment #7)
> Oh.... yes, that would make sense.
> 
> (In reply to Virgil Dicu [:virgil] [QA] from comment #6)
> > If I understood correctly from the description, the add-on is only marked as
> > incompatible in the update screen (while updating from 10b5 to 10b6). The
> > Add-on Manager lists it correctly afterwards. 
> 
> Swarnava, can you confirm this?

absolutely, it is incompatible when prompt update, but after update, it work normally!
Great - thanks. That means this is an intentional bug introduced for testing only on the Beta channel, as per bug 711275.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.