Add tested devices to direct texture whitelist

VERIFIED FIXED in Firefox 11

Status

()

defect
P3
normal
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: snorp, Assigned: snorp)

Tracking

Trunk
Firefox 12
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox11 verified, firefox12 verified, fennec11+)

Details

Attachments

(1 attachment)

QA has done some testing and came up with several devices that are known to work (or at least don't crash) with direct texture enabled. We should update the whitelist with those board names (which is found here: https://wiki.mozilla.org/Mobile/GrallocWhiteList).
Comment on attachment 592173 [details] [diff] [review]
Add known-good devices to direct texture whitelist

Review of attachment 592173 [details] [diff] [review]:
-----------------------------------------------------------------

::: widget/android/AndroidGraphicBuffer.cpp
@@ +454,5 @@
>    sGLFunctions.fImageTargetTexture2DOES(GL_TEXTURE_2D, mEGLImage);
>    return ensureNoGLError("glEGLImageTargetTexture2DOES");
>  }
>  
>  static const char* sAllowedBoards[] = {

let's change this to an nsTArray so we can use Contains() rather than iterating over the whole list
Attachment #592173 - Flags: review?(blassey.bugs) → review-
(Brad gave r+ on IRC)
Depends on: 722605
https://hg.mozilla.org/mozilla-central/rev/f123328d6dac
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED

Comment 6

8 years ago
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #0)
> We should update
> the whitelist with those board names (which is found here:
> https://wiki.mozilla.org/Mobile/GrallocWhiteList).

Why does the patch omit some of the devices on the "Passed Gralloc Tests" list?

saga
vision
speedy
mahimahi
pyramid
lgp970
olympus
begonia
jordan
sunfire

are missing. My HTC Sensation (pyramid) would appreciate being included :-)

Comment 7

8 years ago
(Commenting again because Bugzilla failed to send any bugmail for my last comment. Hopefully it will work this time).

See comment 6.
Comment on attachment 592173 [details] [diff] [review]
Add known-good devices to direct texture whitelist

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
slow painting because gralloc will be disabled where they don't need to be
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #592173 - Flags: review-
Attachment #592173 - Flags: review+
Attachment #592173 - Flags: approval-mozilla-beta?
Attachment #592173 - Flags: approval-mozilla-aurora?
Comment on attachment 592173 [details] [diff] [review]
Add known-good devices to direct texture whitelist

[Triage Comment]
Mobile only - approved for Aurora 12 and Beta 11.
Attachment #592173 - Flags: approval-mozilla-beta?
Attachment #592173 - Flags: approval-mozilla-beta+
Attachment #592173 - Flags: approval-mozilla-aurora?
Attachment #592173 - Flags: approval-mozilla-aurora+
(In reply to Daniel Cater from comment #6)
> (In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #0)
> > We should update
> > the whitelist with those board names (which is found here:
> > https://wiki.mozilla.org/Mobile/GrallocWhiteList).
> 
> Why does the patch omit some of the devices on the "Passed Gralloc Tests"
> list?
> 
> saga
> vision
> speedy
> mahimahi
> pyramid
> lgp970
> olympus
> begonia
> jordan
> sunfire
> 
> are missing. My HTC Sensation (pyramid) would appreciate being included :-)

Most of these were not added because like your Sensation they are Adreno devices, which have never worked. This testing only allowed the device into the whitelist. There is still a feature test done to make sure gralloc actually works, which always fails on Adreno. I don't want to risk it by adding those devices to the whitelist.

Comment 12

7 years ago
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #11)
> (In reply to Daniel Cater from comment #6)
> > (In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #0)
> > > We should update
> > > the whitelist with those board names (which is found here:
> > > https://wiki.mozilla.org/Mobile/GrallocWhiteList).
> > 
> > Why does the patch omit some of the devices on the "Passed Gralloc Tests"
> > list?
> > 
> > saga
> > vision
> > speedy
> > mahimahi
> > pyramid
> > lgp970
> > olympus
> > begonia
> > jordan
> > sunfire
> > 
> > are missing. My HTC Sensation (pyramid) would appreciate being included :-)
> 
> Most of these were not added because like your Sensation they are Adreno
> devices, which have never worked. This testing only allowed the device into
> the whitelist. There is still a feature test done to make sure gralloc
> actually works, which always fails on Adreno. I don't want to risk it by
> adding those devices to the whitelist.

OK, thanks for the explanation. That wasn't clear from the wiki page or the bug summary.

Could you give a minimal testcase for something that doesn't work with an Adreno 220 for example? The Samsung Galaxy S2 has an Adreno 220 in the latest versions so it would be a shame for older versions to be whiltelisted whilst newer versions were not.

Comment 13

7 years ago
All other devices except the one from previous 2 comments were added the the whitelist on Beta, Aurora and Nightly:

 "venus2",     // Motorola Droid Pro
 "tuna",       // Galaxy Nexus
 "omap4sdp",   // Amazon Kindle Fire
 "droid2",     // Motorola Droid 2
 "targa",      // Motorola Droid Bionic
 "spyder",     // Motorola Razr
 "shadow",     // Motorola Droid X
 "SGH-I897",   // Samsung Galaxy S
 "GT-I9100",   // Samsung Galaxy SII
 "sgh-i997",   // Samsung Infuse 4G
 "herring",    // Samsung Nexus S
 "sgh-t839",   // Samsung Sidekick 4G
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.