Last Comment Bug 721804 - GCC 4.6 build warning: image/src/RasterImage.cpp:400:13: warning: variable 'frameToUse' set but not used [-Wunused-but-set-variable]
: GCC 4.6 build warning: image/src/RasterImage.cpp:400:13: warning: variable 'f...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on:
Blocks: buildwarning
  Show dependency treegraph
 
Reported: 2012-01-27 10:38 PST by Daniel Holbert [:dholbert]
Modified: 2012-03-27 03:00 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Daniel Holbert [:dholbert] 2012-01-27 10:38:08 PST
GCC 4.6 build warning:
{
image/src/RasterImage.cpp:400:13: warning: variable 'frameToUse' set but not used [-Wunused-but-set-variable]
}

The only mentions of this variable are:
>398   imgFrame *frameToUse = nsnull;
and
>401     frameToUse = nextFrame;

http://mxr.mozilla.org/mozilla-central/source/image/src/RasterImage.cpp#398
Comment 1 Daniel Holbert [:dholbert] 2012-01-27 10:38:50 PST
CC'ing jwir3 since he touched this code last. :)
Comment 2 Atul Aggarwal 2012-03-27 03:00:41 PDT
Already fixed by http://hg.mozilla.org/mozilla-central/rev/5cc8a9432812

Note You need to log in before you can comment on or make changes to this bug.