Last Comment Bug 721855 - Honour gfx.canvas.azure.prefer-skia pref on OS X
: Honour gfx.canvas.azure.prefer-skia pref on OS X
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla12
Assigned To: George Wright (:gw280) (:gwright)
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-27 13:08 PST by George Wright (:gw280) (:gwright)
Modified: 2012-01-30 02:53 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Use pref on os x (865 bytes, patch)
2012-01-27 13:10 PST, George Wright (:gw280) (:gwright)
jmuizelaar: review-
Details | Diff | Splinter Review
updated patch (1.08 KB, patch)
2012-01-27 13:27 PST, George Wright (:gw280) (:gwright)
jmuizelaar: review-
Details | Diff | Splinter Review
refactor the wooooorld (5.37 KB, patch)
2012-01-27 14:04 PST, George Wright (:gw280) (:gwright)
joe: review+
Details | Diff | Splinter Review
finally final patch (4.64 KB, patch)
2012-01-27 14:38 PST, George Wright (:gw280) (:gwright)
no flags Details | Diff | Splinter Review

Description George Wright (:gw280) (:gwright) 2012-01-27 13:08:18 PST
We should honour that pref on OS X. Currently it's hard coded to use CG.
Comment 1 George Wright (:gw280) (:gwright) 2012-01-27 13:10:09 PST
Created attachment 592239 [details] [diff] [review]
Use pref on os x
Comment 2 Jeff Muizelaar [:jrmuizel] 2012-01-27 13:21:02 PST
Comment on attachment 592239 [details] [diff] [review]
Use pref on os x

Use GetBoolVarCache?
Comment 3 Jeff Muizelaar [:jrmuizel] 2012-01-27 13:22:11 PST
AddBoolVarCache
Comment 4 George Wright (:gw280) (:gwright) 2012-01-27 13:27:46 PST
Created attachment 592251 [details] [diff] [review]
updated patch
Comment 5 Jeff Muizelaar [:jrmuizel] 2012-01-27 13:31:20 PST
Comment on attachment 592251 [details] [diff] [review]
updated patch

This would be better off in gfxPlatform and can be initialized in gfxPlatform's constructor.
Comment 6 George Wright (:gw280) (:gwright) 2012-01-27 14:04:26 PST
Created attachment 592264 [details] [diff] [review]
refactor the wooooorld
Comment 7 Joe Drew (not getting mail) 2012-01-27 14:14:06 PST
Comment on attachment 592264 [details] [diff] [review]
refactor the wooooorld

Review of attachment 592264 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/thebes/gfxD2DSurface.cpp
@@ +127,5 @@
>  const gfxIntSize gfxD2DSurface::GetSize() const
>  { 
>      return gfxIntSize(cairo_d2d_surface_get_width(mSurface),
>                        cairo_d2d_surface_get_height(mSurface));
> +}

THIS IS NOT PERMITTED IN THIS PATCH

::: gfx/thebes/gfxPlatform.h
@@ +449,5 @@
>  
>      // which scripts should be shaped with harfbuzz
>      PRInt32 mUseHarfBuzzScripts;
>  
> +    // The preferred azure backend to use

_DRAW TARGET_ backend

::: gfx/thebes/gfxWindowsPlatform.cpp
@@ +559,3 @@
>    }
> +
> +  return true;

Put the return with the aBackend assignment, and return false outside the if.
Comment 8 George Wright (:gw280) (:gwright) 2012-01-27 14:38:04 PST
Created attachment 592280 [details] [diff] [review]
finally final patch

Pushed to try at https://tbpl.mozilla.org/?tree=Try&rev=28888d108556
Comment 9 George Wright (:gw280) (:gwright) 2012-01-28 15:45:43 PST
Looks like this can be checked in. The TBPL shows that the only test failures are either known intermittent failures, or are already/also present on other completely unrelated tests that have also been pushed to try.
Comment 11 Marco Bonardo [::mak] 2012-01-30 02:53:09 PST
https://hg.mozilla.org/mozilla-central/rev/68b7ab93105f

Note You need to log in before you can comment on or make changes to this bug.