Last Comment Bug 721860 - addonBar keyboard shortcut enabled in non-browser windows
: addonBar keyboard shortcut enabled in non-browser windows
Status: RESOLVED FIXED
[inbound]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: Firefox 13
Assigned To: Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-27 13:28 PST by Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
Modified: 2012-02-09 10:29 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v0.1 (1.24 KB, patch)
2012-01-27 13:36 PST, Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
gavin.sharp: review+
Details | Diff | Review

Description Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-01-27 13:28:42 PST
Looks like it's OS X only (which makes sense since that's the only place the menu overlay is used).
Comment 1 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-01-27 13:36:43 PST
Created attachment 592253 [details] [diff] [review]
Patch v0.1

We disable the toolbars parent menu item, but keyboard shortcuts can still get through (because that's just how we roll), so we need to disable the addon bar command too.
Comment 2 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-02-08 12:06:38 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/a0afbef06c72
Comment 3 Ed Morley [:emorley] 2012-02-09 10:29:07 PST
https://hg.mozilla.org/mozilla-central/rev/a0afbef06c72

Note You need to log in before you can comment on or make changes to this bug.