Last Comment Bug 721888 - Fennec native build doesn't flag java warnings as errors
: Fennec native build doesn't flag java warnings as errors
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All Android
: -- normal (vote)
: Firefox 12
Assigned To: (Back on May31) Kartikaya Gupta (email:kats@mozilla.com)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-27 14:52 PST by (Back on May31) Kartikaya Gupta (email:kats@mozilla.com)
Modified: 2013-12-10 10:00 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
(1/2) Fix last two java warnings (1.34 KB, patch)
2012-01-27 14:52 PST, (Back on May31) Kartikaya Gupta (email:kats@mozilla.com)
blassey.bugs: review+
blassey.bugs: approval‑mozilla‑aurora+
blassey.bugs: approval‑mozilla‑beta+
Details | Diff | Review
(2/2) Add -Werror to javac command-line (1.83 KB, patch)
2012-01-27 14:52 PST, (Back on May31) Kartikaya Gupta (email:kats@mozilla.com)
no flags Details | Diff | Review
(2/2) Add -Werror to JAVAC_FLAGS (1.18 KB, patch)
2012-01-27 18:10 PST, (Back on May31) Kartikaya Gupta (email:kats@mozilla.com)
no flags Details | Diff | Review
(2/2) Add -Werror to JAVAC_FLAGS (507 bytes, patch)
2012-01-27 18:44 PST, (Back on May31) Kartikaya Gupta (email:kats@mozilla.com)
blassey.bugs: review+
blassey.bugs: approval‑mozilla‑beta+
Details | Diff | Review

Description (Back on May31) Kartikaya Gupta (email:kats@mozilla.com) 2012-01-27 14:52:18 PST
Created attachment 592285 [details] [diff] [review]
(1/2) Fix last two java warnings

Now that the websms thing is disabled we have a window of opportunity to turn on warnings-as-errors for java code to prevent introducing more warnings.
Comment 1 (Back on May31) Kartikaya Gupta (email:kats@mozilla.com) 2012-01-27 14:52:47 PST
Created attachment 592287 [details] [diff] [review]
(2/2) Add -Werror to javac command-line
Comment 2 (Back on May31) Kartikaya Gupta (email:kats@mozilla.com) 2012-01-27 14:53:22 PST
I have a try push running to build on all platforms to make sure it doesn't break anything: https://tbpl.mozilla.org/?tree=Try&rev=2067d01d149a
Comment 3 Brad Lassey [:blassey] (use needinfo?) 2012-01-27 17:56:24 PST
Comment on attachment 592287 [details] [diff] [review]
(2/2) Add -Werror to javac command-line

I'd rather you put -Werror in JAVAC_FLAGS
Comment 4 (Back on May31) Kartikaya Gupta (email:kats@mozilla.com) 2012-01-27 18:10:29 PST
Created attachment 592335 [details] [diff] [review]
(2/2) Add -Werror to JAVAC_FLAGS
Comment 5 (Back on May31) Kartikaya Gupta (email:kats@mozilla.com) 2012-01-27 18:44:18 PST
Created attachment 592343 [details] [diff] [review]
(2/2) Add -Werror to JAVAC_FLAGS

cpeterson pointed out a better place to modify JAVAC_FLAGS. sorry for the churn/bugmail.
Comment 8 Brad Lassey [:blassey] (use needinfo?) 2012-01-29 21:53:57 PST
Kats, please request approval for aurora
Comment 9 (Back on May31) Kartikaya Gupta (email:kats@mozilla.com) 2012-01-30 07:18:03 PST
Comment on attachment 592285 [details] [diff] [review]
(1/2) Fix last two java warnings

[Approval Request Comment]
Regression caused by (bug #): 603008
User impact if declined: none; compiler warning fix only
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): possible rebase errors on future patches that affect this code.
Comment 10 Brad Lassey [:blassey] (use needinfo?) 2012-02-06 16:22:35 PST
Comment on attachment 592285 [details] [diff] [review]
(1/2) Fix last two java warnings

[Triage Comment]
approved for beta as well
Comment 11 Brad Lassey [:blassey] (use needinfo?) 2012-02-06 16:25:25 PST
Comment on attachment 592343 [details] [diff] [review]
(2/2) Add -Werror to JAVAC_FLAGS

[Triage Comment]
now approved for beta

Note You need to log in before you can comment on or make changes to this bug.