<HR> with auto width causes a wrong position

VERIFIED DUPLICATE of bug 20582

Status

()

Core
CSS Parsing and Computation
VERIFIED DUPLICATE of bug 20582
17 years ago
17 years ago

People

(Reporter: wata7, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.12 i386; en-US; m18) Gecko/20010131
Netscape6/6.01
BuildID:

<HR> with specified margin-left/right lengths and auto width causes a
wrong position.


Reproducible: Always
Steps to Reproduce:
Browse the following HTML.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN">
<HTML><HEAD><TITLE>test</TITLE>
<STYLE TYPE="text/css">
HR {
  margin-left: 25%;
  margin-right: 25%;
  width: auto;
}
</STYLE></HEAD>
<BODY>
<HR>
</BODY>
</HTML>


Actual Results:  margin-left will be 75% and width will be 100%.

Expected Results:  margin-left should be 25% and width should be 50%.

This bug occurs only when we use the strict DTD.  The transitional DTD
never cause this problem.
Duplicate.

*** This bug has been marked as a duplicate of 20582 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
close enough... this will be fixed when my patch is checked in, anyway.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.