android crashes when pairing a device

RESOLVED DUPLICATE of bug 718703

Status

()

P1
normal
RESOLVED DUPLICATE of bug 718703
7 years ago
a year ago

People

(Reporter: mluna, Unassigned)

Tracking

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 beta+)

Details

(Whiteboard: [MTD], sync, [native-crash])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 592314 [details]
verbose crash log from DDMS

Web page or screen you were on when you saw the issue: pair device in application settings 

Steps to reproduce:
1. setup sync on aurora, then click setup sync button again
2. clicked my name | sync is on
3. click pair device and it crashes the phone (nexus one, running gingerbread)

What you expected: maybe related to 718703? not sure. This is 100% reproducible, it also looses all the sync settings in aurora. 

Crash report ID (if applicable): no crash report, but I captured a log from Cheng's phone
Component: General → Android Sync
Product: Fennec Native → Mozilla Services
QA Contact: general → android-sync
Whiteboard: [MTD] → [MTD], sync, [native-crash]
Version: Firefox 11 → unspecified
Hey Michelle,

Can you grab /data/anr/traces.txt from the device?

If I had to guess from the log, it's not us:

01-27 15:52:36.234: INFO/ActivityManager(21218): Process org.zeam.core (pid 21300) has died.
01-27 15:52:36.234: INFO/WindowManager(21218): WIN DEATH: Window{408bb588 org.zeam/org.zeam.Launcher paused=false}

Zeam is the launcher. But only the traces dump will tell…

Thanks!
(Reporter)

Comment 2

7 years ago
Hi,

Sorry, it was Cheng's phone, so I can't get the traces file. Cheng will have to give it a try, he is cc'd.

Thanks,
Michelle
Priority: -- → P1
Assignee: nobody → xyuan
Assignee: xyuan → nobody
Still a problem, Michelle?
Severity: critical → normal
FWIW, i havent seen this crash happen since bug 718703 was fixed back around Feb 7th.
Suspect it's a dupe, if not and someone reopens, marked as beta blocking so it doesn't fall under radar.
Status: NEW → RESOLVED
blocking-fennec1.0: --- → beta+
Last Resolved: 7 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
Keywords: qawanted
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 718703
Component: Android Sync → Android Sync
Product: Mozilla Services → Android Background Services

Updated

a year ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.