Last Comment Bug 722046 - remove extra semicolon after NS_DECl_EVENT_HANDLER
: remove extra semicolon after NS_DECl_EVENT_HANDLER
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: x86 OpenBSD
: -- normal (vote)
: mozilla12
Assigned To: Landry Breuil (:gaston)
:
Mentors:
Depends on: 718132
Blocks: buildwarning
  Show dependency treegraph
 
Reported: 2012-01-28 06:07 PST by Landry Breuil (:gaston)
Modified: 2012-01-28 18:48 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove extra semicolons (1.59 KB, patch)
2012-01-28 06:13 PST, Landry Breuil (:gaston)
Ms2ger: review+
Details | Diff | Review
Remove extra semicolons (4.21 KB, patch)
2012-01-28 07:24 PST, Landry Breuil (:gaston)
Ms2ger: review+
Details | Diff | Review

Description Landry Breuil (:gaston) 2012-01-28 06:07:25 PST
Followup to bug #718132, (and similar to #704729) m-c fails now on OpenBSD/gcc 4.2.1 with a bunch of :
In file included from ../../dist/include/mozilla/dom/indexedDB/IndexedDatabaseManager.h:45,
                 from ../../dist/include/mozilla/dom/indexedDB/FileInfo.h:46,
                 from ../../dist/include/nsDOMFile.h:56,
                 from /home/landry/src/mozilla-central/layout/forms/../../content/html/content/src/nsHTMLInputElement.h:51,
                 from /home/landry/src/mozilla-central/layout/forms/nsFileControlFrame.cpp:67:
../../dist/include/mozilla/dom/indexedDB/IDBDatabase.h:158: error: extra ';'
../../dist/include/mozilla/dom/indexedDB/IDBDatabase.h:159: error: extra ';'
../../dist/include/mozilla/dom/indexedDB/IDBDatabase.h:160: error: extra ';'
In file included from ../../dist/include/mozilla/dom/indexedDB/IndexedDatabaseManager.h:46,
                 from ../../dist/include/mozilla/dom/indexedDB/FileInfo.h:46,
                 from ../../dist/include/nsDOMFile.h:56,
                 from /home/landry/src/mozilla-central/layout/forms/../../content/html/content/src/nsHTMLInputElement.h:51,
                 from /home/landry/src/mozilla-central/layout/forms/nsFileControlFrame.cpp:67:
../../dist/include/mozilla/dom/indexedDB/IDBRequest.h:161: error: extra ';'
../../dist/include/mozilla/dom/indexedDB/IDBRequest.h:162: error: extra ';'

Patch incoming..
Comment 1 Landry Breuil (:gaston) 2012-01-28 06:13:05 PST
Created attachment 592396 [details] [diff] [review]
Remove extra semicolons
Comment 2 Landry Breuil (:gaston) 2012-01-28 06:20:12 PST
And it seems it's very similar to bug #720815 which resolution only fixed one of three occurences..
Comment 3 :Ms2ger 2012-01-28 06:49:30 PST
Comment on attachment 592396 [details] [diff] [review]
Remove extra semicolons

r=me if you also fix the others at <http://mxr.mozilla.org/mozilla-central/ident?i=NS_DECL_EVENT_HANDLER>
Comment 4 Landry Breuil (:gaston) 2012-01-28 07:24:40 PST
Created attachment 592401 [details] [diff] [review]
Remove extra semicolons

Sure, here you are. Wonder why IDBTransaction.h didn't error out first (i can understand for dom/telephony)
Comment 5 :Ms2ger 2012-01-28 07:53:23 PST
Comment on attachment 592401 [details] [diff] [review]
Remove extra semicolons

Thanks. (Don't forget to update your commit message.)
Comment 6 Landry Breuil (:gaston) 2012-01-28 08:01:10 PST
I can't edit the commit message without reposting a new patch & reasking for review, and i didn't hit the other occurences.. so, to whoever commits the diff, please remove the extra error lines and only keep the summary line. (is it the right way to do it ?)
Comment 7 Daniel Holbert [:dholbert] 2012-01-28 12:10:05 PST
Pushed:
 https://hg.mozilla.org/integration/mozilla-inbound/rev/d9a514effc2a

Also, for future reference:

(In reply to Landry Breuil from comment #6)
> I can't edit the commit message without reposting a new patch & reasking for
> review

Don't worry about reasking for review in that case -- if someone grants you r+ with a few changes requested, general practice is to re-post without needing to ask for review on the new patch.  (Just be sure not to obsolete the old patch, so that whoever pushes the patch will see that an earlier version has gotten r+ & can easily compare the two versions)

(No need to do that here, though, as I've already pushed the patch w/ updated commit message)

> please remove the extra error lines and only keep the summary line.
> (is it the right way to do it ?)

Yup -- single-line commit messages are the standard practice for mozilla repositories.
(like "Bug XXX: change foo to bar. r=whoever")
Comment 8 Daniel Holbert [:dholbert] 2012-01-28 12:10:37 PST
(adding "buildwarning" keyword since this caused build warnings on Linux GCC 4.6)
Comment 9 Daniel Holbert [:dholbert] 2012-01-28 12:11:17 PST
(er s/keyword/bug-dependency/. Finished with bugspam now, sorry. :))
Comment 10 Joe Drew (not getting mail) 2012-01-28 18:48:09 PST
https://hg.mozilla.org/mozilla-central/rev/d9a514effc2a

Note You need to log in before you can comment on or make changes to this bug.