Last Comment Bug 722068 - Sub-tile invalidation isn't working properly on pages with animations
: Sub-tile invalidation isn't working properly on pages with animations
Status: RESOLVED FIXED
[not-fennec-11]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: -- major (vote)
: Firefox 12
Assigned To: Chris Lord [:cwiiis]
:
:
Mentors:
Depends on:
Blocks: 717283
  Show dependency treegraph
 
Reported: 2012-01-28 10:52 PST by Patrick Walton (:pcwalton)
Modified: 2013-12-10 10:00 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
fixed
fixed


Attachments
Fix invalidation of MultiTileLayer during animations (7.21 KB, patch)
2012-01-30 07:49 PST, Chris Lord [:cwiiis]
pwalton: review+
Details | Diff | Splinter Review

Description Patrick Walton (:pcwalton) 2012-01-28 10:52:26 PST
I see random tiles flickering in and out of view on pages with animations. Often I see a tile that's completely blank except for the animated bit. It looks like subtile invalidation isn't working.
Comment 1 Patrick Walton (:pcwalton) 2012-01-29 09:41:50 PST
It works when remaining still on pages with animations, but when panning around it causes the behavior described above.
I don't think we can uplift tiling to Aurora before this is fixed.
Comment 2 Chris Lord [:cwiiis] 2012-01-30 03:37:46 PST
Looking at this, I can reproduce on http://www.kevs3d.co.uk/dev/asteroidsbench/
Comment 3 Chris Lord [:cwiiis] 2012-01-30 03:38:56 PST
Well, I can't reproduce random tiles flickering, but tiles that have sub-region updates end up with only the updated region and the rest of the tile disappears. If random tiles are disappearing entirely, that may be a different problem, but hopefully we're talking about the same thing.
Comment 4 Chris Lord [:cwiiis] 2012-01-30 07:49:30 PST
Created attachment 592715 [details] [diff] [review]
Fix invalidation of MultiTileLayer during animations

This fixes invalidations during animations. We were using getOrigin/getResolution to compare newly set origins/resolutions with the previously set one, but if two updates happened in quick succession, the layer could be locked for long enough that an update wouldn't happen and so the buffer would be incorrectly invalidated.
Comment 5 Patrick Walton (:pcwalton) 2012-01-30 21:21:22 PST
Comment on attachment 592715 [details] [diff] [review]
Fix invalidation of MultiTileLayer during animations

Review of attachment 592715 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine. Definitely an improvement. Unfortunately it's hard for me to tell whether this actually fully fixes the problem due to the layout regression (which I tried backing out, but the problem still exists... it'll take more time than I threw at it.)
Comment 6 Ed Morley [:emorley] 2012-01-31 08:52:01 PST
https://hg.mozilla.org/mozilla-central/rev/8919c54229e1
Comment 7 Brad Lassey [:blassey] (use needinfo?) 2012-02-05 14:21:56 PST
patrick, should this be uplifted?
Comment 8 Brad Lassey [:blassey] (use needinfo?) 2012-02-06 16:27:02 PST
Chris, please request beta approval and make sure this applies in the landing patch queue
Comment 9 Kartikaya Gupta (email:kats@mozilla.com) 2012-02-08 12:13:28 PST
Already in aurora (Fx 12).

Not needed in beta as it is a follow-up for bug 717283 which isn't in beta.

Note You need to log in before you can comment on or make changes to this bug.