When opening a new tab, Firefox accesses disk causing it to spin-up.

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: milesss, Unassigned)

Tracking

({regression})

9 Branch
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111223105406

Steps to reproduce:

1. Enable idle-spin-down on my HDD.
2. Wait for a while for disk to spin down.
3. Press Ctrl+T.


Actual results:

Disk spins up each time.


Expected results:

Silence.
(Reporter)

Updated

7 years ago
Keywords: regression

Comment 1

7 years ago
I'd think Firefox needs to add the new tab to its session restore / crash restore file so it needs to spin up the disk.
Component: Untriaged → Session Restore
QA Contact: untriaged → session.restore
This seems pretty unrelated to session restore - it's just about opening a new tab.

There's a bug on the fact that opening a tab uses some memory, but I haven't seen anything about excessive HDD spin.

Milesss, you said this was a regression. At what point did this work?
Component: Session Restore → Tabbed Browser
QA Contact: session.restore → tabbed.browser
(In reply to Paul O'Shannessy [:zpao] from comment #2)
> This seems pretty unrelated to session restore - it's just about opening a
> new tab.

Oops! Actually opening a new tab does result in Session Restore saving the session file, exactly as aceman said. The only option is to get a little bit more intelligent about deciding to save the file.
Component: Tabbed Browser → Session Restore
QA Contact: tabbed.browser → session.restore
(Reporter)

Comment 4

7 years ago
I added regression keyword, because a few years ago there was similar problem with firefox caused by sqlite (https://bugs.launchpad.net/ubuntu/+source/firefox-3.0/+bug/221009).

I enabled disk spin down recently, so in fact I can't tell if there was point it worked.

Disk spins up also when closing tabs or visiting a new page.
Thanks for reporting, but I'm going to mark this INVALID (could be interpreted as WONTFIX a request to change the behavior) - we write the sessionstore.js file to disk when there is recent activity and that's not going to change. Turning off crash recovery will mostly help you (unless you have pinned tabs).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.