Closed Bug 722116 Opened 12 years ago Closed 12 years ago

'20120128' SeaMonkey browser non-functional

Categories

(SeaMonkey :: UI Design, defect)

x86
Windows 7
defect
Not set
normal

Tracking

(seamonkey2.8 unaffected, seamonkey2.9 fixed)

VERIFIED FIXED
seamonkey2.9
Tracking Status
seamonkey2.8 --- unaffected
seamonkey2.9 --- fixed

People

(Reporter: bleahrimasu, Assigned: standard8)

References

Details

(Whiteboard: [fixed by bug 714277])

Attachments

(1 file)

Attached image nukemonkey.png
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:12.0a1) Gecko/20120128 Firefox/12.0a1
Build ID: 20120128031108

Steps to reproduce:

Latest autoupdate trunk build 20120128 nukes browser, rendering it non-functional.


Actual results:

Location bar: non-functional. Typing any url and clicking go/enter doesn't cause browser to go to url

Bookmarks: Bookmarks toolbar disappears.

Top menu: File, Edit, View submenus missing. Clicking on any menu including bookmark menu does not produce a response from browser.


Expected results:

A functional seamonkey.
Sounds like a broken extension. Try starting in safe mode e.g.

c:\path\to\seamonkey.exe -safe-mode
Reproducible under safe mode. In particular: Menu and sub-menu items all produce no response even in safe mode.

With seamonkey.exe -silent -jsconsole, I get 2 error dialogues:

warningTimestamp: 29/1/2012 1:17:58 PM
Warning: Ignoring obsolete chrome registration modifier 'xpcnativewrappers=no'.
Source File: jar:file:///C:/Users/User/AppData/Roaming/Mozilla/SeaMonkey/Profiles/dad/extensions/inspector@mozilla.org.xpi!/chrome.manifest
Line: 22

Timestamp: 29/1/2012 1:17:59 PM
Error: undefined entity
Source File: chrome://communicator/content/utilityOverlay.xul
Line: 122, Column: 5
Source Code:
<iframe id="customizeToolbarSheetIFrame"
Mozilla/5.0 (X11; Linux x86_64; rv:12.0a1) Gecko/20120128 Firefox/12.0a1 SeaMonkey/2.9a1 ID:20120128003009

Works for me, but:
- this is linux64, not Windows
- I'm using a third-party theme (EarlyBlue, and in fact not even the AMO version but the latest bleeding-edge version which appeared today on the git repo), not Modern as in the screenshot and not the default theme as you saw it in safe mode.

I. Try running SeaMonkey in a fresh profile:
1. seamonkey -ProfileManager
2. create a new profile
3. use it

II. If the problem is still present in the new profile, then try the following:
1. Download either (or both) the installer.exe or the zip build found at http://ftp.mozilla.org/pub/seamonkey/nightly/latest-comm-central-trunk/
2. Uninstall SeaMonkey, removing the application directory with all its contents but not your profile (if the uninstall asks permission to remove your user data, answer "No" or the equivalent).
3. Install the build downloaded at step 1.
4. Run the newly installed SeaMonkey.
This may or may not cure the problem. It should cure it if the auto-update was incorrect or if the problem was due to a mixed set of files from different SeaMonkey builds. If the problem is still present in both profiles (your usual one and the new one you created in I above) after uninstall-reinstall, then it is really serious: either something with your Windows registry, or something wrong with today's Windows nightly but not with the corresponding Linux nightly.
P.S. The latest-comm-central-trunk directory mentioned above contains both the last 2.8a1 builds (from 20 December) and the latest 2.9a1 builds (usually no more than a day old). You should of course use the latter.
I can reproduce this bug in latest tinderbox build too. It happens with a clean profile also. I am using XP 32bit. 
Last good build 20120127.
Fixed by:http://hg.mozilla.org/comm-central/rev/1694822c492e
Fix comm-central bustage from string rename and change in m-c bug 714277. r=bustage-fix.
In reply to comment #5 and #6:
Sven, do you know the exact yyyyMMddhhmmss timestamp when the source of your tinderbox-build was pulled? The Nightly Tester Tools extension, if installed, can tell you (Tools → Nightly Tester Tools → Insert Build ID into Textbox) or it can also be found in the seamonkey-2.9a1.en-US.win32.txt file accompanying the .installer.exe and .zip in the same directory on ftp.mozilla.org — from what I read at http://tinderbox.mozilla.org/showbuilds.cgi?tree=SeaMonkey&hours=36 and at http://hg.mozilla.org/comm-central/shortlog/ there ought to have been a win32 tinderbox-build made from source containing the changeset mentioned in comment #6 some 12 hours before you posted comment #5: I see in column "WINNT 5.2 comm-central-trunk build" a build made from comm-central changeset db9e96b875aa which immediately followed the one mentioned by Philip, and whose build ended on 2012-01-28 12:29 PST, and (by now) two later builds in the same column.
I just installed tinderbox build 20120129 and the bug is fixed.
OK, let's declare it FIXED then (not WFM as we have a changeset number in comment #6) and VERIFIED according to comment #8.

Sven: When you said "tinderbox build" in comment #5 and #8, maybe you meant "nightly build" instead? (a nightly build, with lowercase, it produced once every 24 hours, not to be confused with Nightly, with uppercase, which is the current code name for Firefox trunk; tinderbox builds, often called "hourlies" are produced oftener than that; see e.g. the nightly/ and tinderbox-builds/ subdirectories of http://ftp.mozilla.org/pub/mozilla.org/seamonkey/
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Component: General → UI Design
QA Contact: general → ui-design
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.9
Status: RESOLVED → VERIFIED
Depends on: 714277
Assignee: nobody → philip.chee
Assignee: philip.chee → nobody
Assignee: nobody → mbanner
Flags: in-testsuite-
Summary: 2012128 browser non-functional → '20120128' SeaMonkey browser non-functional
Whiteboard: [fixed by bug 714277]
You need to log in before you can comment on or make changes to this bug.