Last Comment Bug 722127 - Build --with-system-libvpx is broken for libvpx-1.0.0
: Build --with-system-libvpx is broken for libvpx-1.0.0
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla12
Assigned To: ojab
:
:
Mentors:
http://git.chromium.org/gitweb/?p=web...
Depends on:
Blocks: 741737
  Show dependency treegraph
 
Reported: 2012-01-28 23:59 PST by ojab
Modified: 2012-04-03 03:58 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
libvpx-1.0.0 has VPX_CODEC_USE_INPUT_FRAGMENTS define (1.27 KB, patch)
2012-01-29 21:49 PST, ojab
tterribe: review-
Details | Diff | Splinter Review
Updated patch, bump requred libvpx version to 1.0.0 (2.77 KB, patch)
2012-01-30 00:02 PST, ojab
tterribe: review+
Details | Diff | Splinter Review

Description ojab 2012-01-28 23:59:20 PST
libvpx-1.0.0 is out (link to the changelog in URL), but firefox's configure fails to find system libvpx:

$ make -f client.mk  
…
checking for libvpx version >= v0.9.7... no
configure: error: --with-system-libvpx requested but it is not v0.9.7 or later

There is no VPX_CODEC_USE_INPUT_PARTITION define in libvpx-1.0.0 source tree.
Comment 1 Timothy B. Terriberry (:derf) 2012-01-29 13:02:44 PST
Yeah, the API isn't quite as compatible as the CHANGELOG would suggest. I'll take care of this.
Comment 2 ojab 2012-01-29 21:49:07 PST
Created attachment 592612 [details] [diff] [review]
libvpx-1.0.0 has VPX_CODEC_USE_INPUT_FRAGMENTS define

It seems that VPX_CODEC_USE_INPUT_PARTITION was changed to VPX_CODEC_USE_INPUT_FRAGMENTS in 1.0.0.
Comment 3 Timothy B. Terriberry (:derf) 2012-01-29 23:21:34 PST
Comment on attachment 592612 [details] [diff] [review]
libvpx-1.0.0 has VPX_CODEC_USE_INPUT_FRAGMENTS define

I think we actually want to drop support for v0.9.7, because of bug 696390. Just change the check to look for VPX_CODEC_USE_INPUT_FRAGMENTS only. That makes the comment above the check wrong (v1.0.0 does have new symbols we could check for, but they're encoder-only, and we currently don't require encode support). The version in the error message we give when v0.9.7 isn't found will also need to be updated.
Comment 4 ojab 2012-01-30 00:02:37 PST
Created attachment 592622 [details] [diff] [review]
Updated patch, bump requred libvpx version to 1.0.0
Comment 6 Matt Brubeck (:mbrubeck) 2012-01-30 19:14:06 PST
https://hg.mozilla.org/mozilla-central/rev/e73a68477cfd
Comment 7 Jory A. Pratt 2012-03-01 19:50:45 PST
(In reply to ojab from comment #2)
> Created attachment 592612 [details] [diff] [review]
> libvpx-1.0.0 has VPX_CODEC_USE_INPUT_FRAGMENTS define
> 
> It seems that VPX_CODEC_USE_INPUT_PARTITION was changed to
> VPX_CODEC_USE_INPUT_FRAGMENTS in 1.0.0.

This makes no sense anymore, we could simple use the pkgconfig file to setup the libs/cflags even check version. This would make it much more robust and simply the code greatly.
Comment 8 Timothy B. Terriberry (:derf) 2012-03-01 20:29:58 PST
(In reply to Jory A. Pratt from comment #7)
> This makes no sense anymore, we could simple use the pkgconfig file to setup
> the libs/cflags even check version. This would make it much more robust and
> simply the code greatly.

We'd probably take a patch to use pkgconfig. Feel free to open a new bug about it.
Comment 9 Martin Stránský 2012-04-03 03:58:17 PDT
Pkgconfig bug/patch filled as bug 741737.

Note You need to log in before you can comment on or make changes to this bug.