Last Comment Bug 722129 - Tilt visualization mesh isn't correctly positioned when scrollbars are present or when the document body is smaller than the content window
: Tilt visualization mesh isn't correctly positioned when scrollbars are presen...
Status: RESOLVED FIXED
[tilt]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: 12 Branch
: All All
: -- normal (vote)
: Firefox 13
Assigned To: Victor Porof [:vporof][:vp]
:
Mentors:
Depends on: 719877
Blocks: 715970
  Show dependency treegraph
 
Reported: 2012-01-29 00:20 PST by Victor Porof [:vporof][:vp]
Modified: 2012-02-13 06:54 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (3.53 KB, patch)
2012-01-29 00:25 PST, Victor Porof [:vporof][:vp]
no flags Details | Diff | Splinter Review
v2 (7.23 KB, patch)
2012-01-29 06:50 PST, Victor Porof [:vporof][:vp]
no flags Details | Diff | Splinter Review
v3 (2.78 KB, patch)
2012-01-29 10:08 PST, Victor Porof [:vporof][:vp]
rcampbell: review+
Details | Diff | Splinter Review

Description Victor Porof [:vporof][:vp] 2012-01-29 00:20:00 PST
For example:

Open a webpage with a scrollbar.
Open inspector.
Open tilt.

The intro and outro animations clearly doesn't take the current scrollbar width (if present) into consideration. This makes things ugly.

Also: open a page with a small body in Tilt. For example, tbpl or about:blank. The mesh is centered in a weird way on the Y axis.
Comment 1 Victor Porof [:vporof][:vp] 2012-01-29 00:25:06 PST
Created attachment 592475 [details] [diff] [review]
v1

Does this need a test?
Comment 2 Victor Porof [:vporof][:vp] 2012-01-29 04:37:20 PST
Comment on attachment 592475 [details] [diff] [review]
v1

(In reply to Victor Porof from comment #1)
> Created attachment 592475 [details] [diff] [review]
> v1
> 
> Does this need a test?

Of course it doesn't because it breaks some existing ones :)
Comment 3 Victor Porof [:vporof][:vp] 2012-01-29 06:50:02 PST
Created attachment 592501 [details] [diff] [review]
v2
Comment 4 Victor Porof [:vporof][:vp] 2012-01-29 10:08:17 PST
Created attachment 592518 [details] [diff] [review]
v3

The solution was much, much easier. No need to calculate scrollbar dimensions.
Comment 5 Victor Porof [:vporof][:vp] 2012-01-30 00:24:09 PST
Comment on attachment 592518 [details] [diff] [review]
v3

This survived try: https://tbpl.mozilla.org/?tree=Try&rev=ce9d3ecd89e5
So much green!
Comment 6 Rob Campbell [:rc] (:robcee) 2012-02-10 07:27:23 PST
https://hg.mozilla.org/integration/fx-team/rev/a82b581bd1b0
Comment 7 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-02-13 06:54:34 PST
https://hg.mozilla.org/mozilla-central/rev/a82b581bd1b0

Note You need to log in before you can comment on or make changes to this bug.