Closed Bug 722194 Opened 9 years ago Closed 7 years ago

Opening bookmarks in a new tab causes Firefox to switch to the new tab immediately, even if the option is not selected in the options menu

Categories

(Firefox :: Untriaged, defect)

9 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 469456

People

(Reporter: kristof.vandebeek, Unassigned)

Details

(Whiteboard: DUPME)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

1. Open the options menu in Firefox (9.0.1)
2. Go to the 'tabs' section in the options menu
3. Disable the option 'when I open a link in a new tab, switch to it immediately'
4. Open your bookmarks menu so it is opened on the left side of the browser
5. Right-click a link and from the pop-up menu select 'open in a new tab'





Actual results:

Firefox will indeed open the bookmark in a new tab, but it will also switch immediately to the tab, even though the option is not enabled in the options menu.


Expected results:

Firefox should not have switched to the newly opened tab, instead it should have opened the link in a different tab and remain on the current tab until the user switches to the newly opened tab manually.
Priority: -- → P4
Please note, the step 'right-click a link' in the 'steps to reproduce' actually means 'right-click a bookmark'.
What page is open in the tab at the time (if it is an app tab - bug 579872 applies)
Are you opening multiple bookmarks (if so - bug 440093 applies)
Priority: P4 → --
Whiteboard: DUPME
There's no specific tab open at the moment - it can be literally any page.
I see this happen all the time now too.

Firefox 15.0.1, on Windows XP.
It's really annoying.

I have verified that I do NOT have the following preference set:

Options->Tabs->"When I open a link in a new tab, switch to it immediately"
This is a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=469456.

It is indeed very annoying. The rationale for bookmarks not using this preference setting seems to be a result of splitting hairs over the words "link" and "bookmark". But just like all rectangles are squares, all bookmarks are links - and this setting should apply to both.
It sure would be great if I could fix my post to say "just like all squares are rectangles..."
As James pointed out, this is a duplicate of bug 469456.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 469456
You need to log in before you can comment on or make changes to this bug.