Dynamic language selection for spell checking does not deliver

RESOLVED DUPLICATE of bug 69687

Status

()

RESOLVED DUPLICATE of bug 69687
7 years ago
7 years ago

People

(Reporter: davidbourguignon.net, Unassigned)

Tracking

9 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 592645 [details]
When the problem occurs...

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

I wrote an email with one paragraph in French and one in English. I then selected "French" for the spell checking. It correctly detected that the second paragraph, in English, was full of mistakes. I then clicked on "Send" and the automatic spell checking window appeared. However, the dictionary selected was now US English!


Actual results:

The automatic spell checking, before sending the email, has changed the pre-set dictionary selection... (I haven't figured out if the switch to US English was due to a dysfunctional dynamic language selection algorithm, or something else.)


Expected results:

Either the user-set dictionary shouldn't have changed (conservative solution, at least defaulting to what the user is expecting) or there should be some effective multi-lingual spell checking (considering some parts of the email as French, some as US English, etc.) Thanks in advance for your help!
Any error in Tools -> Error console when it happenend David ?
(Reporter)

Comment 2

7 years ago
Thanks Ludovic! I checked: yes, there is something that gets printed in the Error Console at the very end (when clicking on "Send", when the automatic spell checking window pops in). Here it is (in French, since I'm using the localized version of Thunderbird):

Avertissement : Une chaîne vide a été transmise à getElementById().
Fichier Source : chrome://editor/content/EdSpellCheck.xul
Ligne : 0

What do you think? Thanks in advance!
Component: Message Compose Window → Spelling checker
Product: Thunderbird → Core
QA Contact: message-compose → spelling-checker
Version: 9 → 9 Branch

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 69687
You need to log in before you can comment on or make changes to this bug.