Closed Bug 722261 Opened 8 years ago Closed 7 years ago

We repaint large sections of web pages when the video controls are visible and the video is playing

Categories

(Toolkit :: Video/Audio Controls, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: jaws, Unassigned)

References

Details

STR:
1) Enable the nglayout.debug.paint_flashing setting in about:config
2) Go to http://www.mozilla.org/projects/firefox/prerelease.html
3) Click play on the video

Expected results:
4) When the video controls are visible, only the visible controls should be flashing.

Actual results:
4) The containing block element div#main.with-menu flashes whenever the video is playing and the controls are visible.
It becomes 'worse' when the volume slider is up.
I think this is basically a dupe of bug 511163. In this case the video is inside a float so we suffer from "the float invalidation" bug (bug 546362), and that makes us invalidate more in this case.
Fixed by DLBI.
Status: NEW → RESOLVED
Closed: 7 years ago
Depends on: dlbi
No longer depends on: 511163
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.