Last Comment Bug 722510 - Remove no-longer-used argument from nsBlockFrame::DrainOverflowLines(nsBlockReflowState& aState)
: Remove no-longer-used argument from nsBlockFrame::DrainOverflowLines(nsBlockR...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout: Block and Inline (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla12
Assigned To: Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th)
:
Mentors:
Depends on: 492627
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-30 14:52 PST by Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th)
Modified: 2012-01-31 06:57 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1 (2.33 KB, patch)
2012-01-30 14:54 PST, Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th)
roc: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2012-01-30 14:52:08 PST
The method
   nsBlockFrame::DrainOverflowLines(nsBlockReflowState& aState)
no longer uses its argument aState.

These csets removed the last usages, as part of bug 492627:
http://hg.mozilla.org/mozilla-central/diff/28008648ca04/layout/generic/nsBlockFrame.cpp#l1.185
http://hg.mozilla.org/mozilla-central/diff/e9130436ada8/layout/generic/nsBlockFrame.cpp#l1.436

It looks like we can just take DrainOverflowLines() argumentless now.
Comment 1 Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2012-01-30 14:54:39 PST
Created attachment 592876 [details] [diff] [review]
fix v1

I think this'll do it. (haven't finished rebuilding yet though)
Comment 2 Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2012-01-30 17:17:47 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/94bae0abad47
Comment 3 Ed Morley [:emorley] 2012-01-31 06:57:15 PST
https://hg.mozilla.org/mozilla-central/rev/94bae0abad47

Note You need to log in before you can comment on or make changes to this bug.