Last Comment Bug 722622 - no_such_method_trace (trace function for NoSuchMethod objects) is unnecessary
: no_such_method_trace (trace function for NoSuchMethod objects) is unnecessary
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla13
Assigned To: general
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-30 22:01 PST by Jim Blandy :jimb
Modified: 2012-02-01 11:23 PST (History)
1 user (show)
jimb: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove custom trace function from js_NoSuchMethodClass. (1.49 KB, patch)
2012-01-30 22:01 PST, Jim Blandy :jimb
jwalden+bmo: review+
Details | Diff | Splinter Review

Description Jim Blandy :jimb 2012-01-30 22:01:02 PST
Created attachment 592996 [details] [diff] [review]
Remove custom trace function from js_NoSuchMethodClass.

This is kind of embarrassing, but:

Since js_NoSuchMethodClass is a native class, it doesn't need a custom trace function; the normal slot traversal will reach the function and id slots. I've verified this in the debugger, and will later be proposing a patch that actually verifies that the slots are being marked properly.
Comment 1 Jim Blandy :jimb 2012-01-31 06:26:05 PST
Try: https://tbpl.mozilla.org/?tree=Try&rev=fa7f1b5bc7e0

I've also run all the tests in js/src/tests and js/src/jit-test that use __noSuchMethod__ with --gczeal=1 and --gczeal=2; seems fine.
Comment 4 Ed Morley [:emorley] 2012-02-01 11:23:35 PST
https://hg.mozilla.org/mozilla-central/rev/fc6b5d8a8001

Note You need to log in before you can comment on or make changes to this bug.