Last Comment Bug 722636 - "Undo Add to Dictionary" context menu is displayed outside of text fields
: "Undo Add to Dictionary" context menu is displayed outside of text fields
Status: VERIFIED FIXED
[qa+]
:
Product: Core
Classification: Components
Component: Spelling checker (show other bugs)
: 12 Branch
: All All
: -- normal with 1 vote (vote)
: mozilla13
Assigned To: Matthew N. [:MattN] (PM me if requests are blocking you)
:
: Jet Villegas (:jet)
Mentors:
Depends on: 352037
Blocks: 715410
  Show dependency treegraph
 
Reported: 2012-01-31 00:42 PST by Matthew N. [:MattN] (PM me if requests are blocking you)
Modified: 2013-12-27 14:27 PST (History)
6 users (show)
MattN+bmo: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
verified


Attachments
v.1 Show (with separator) when "Check spelling" is shown (with tests) (13.77 KB, patch)
2012-01-31 00:42 PST, Matthew N. [:MattN] (PM me if requests are blocking you)
ehsan: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Matthew N. [:MattN] (PM me if requests are blocking you) 2012-01-31 00:42:30 PST
Created attachment 593014 [details] [diff] [review]
v.1 Show (with separator) when "Check spelling" is shown (with tests)

The new "Undo Add to Dictionary" context menu entry is displayed independent of what the user right-clicked once there is an addition to undo.  This means that "Undo Add to Dictionary" appears as the *first* context menu item on images, links, documents, etc.  This gets annoying since the dictionary entry could have been hours ago and people are used to the order of the context menu items.

In my opinion, "Undo Add to Dictionary" should only appear when the "Check spelling" checkbox is displayed (in text fields).
Comment 1 Matthew N. [:MattN] (PM me if requests are blocking you) 2012-01-31 01:32:40 PST
Nominated for tracking-firefox12:
Gaving the first context menu everywhere be "Undo Add to Dictionary" after adding a word to the dictionary has a significant usability impact.  ie. Users expect "Open link in New Tab" first in the menu on links.
Comment 2 :Ehsan Akhgari 2012-01-31 09:11:40 PST
Comment on attachment 593014 [details] [diff] [review]
v.1 Show (with separator) when "Check spelling" is shown (with tests)

Looks very good, thanks!
Comment 3 Asa Dotzler [:asa] 2012-02-07 00:45:45 PST
Yeah. We should try to get this uplifted to where the regression happened or back out the change until it can land with this fix.
Comment 4 Matthew N. [:MattN] (PM me if requests are blocking you) 2012-02-07 01:37:49 PST
I'm going to land it on m-c in the next day and then request approval for Aurora
Comment 5 Matthew N. [:MattN] (PM me if requests are blocking you) 2012-02-08 00:06:16 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/36b986ef4b5b

Try run: https://tbpl.mozilla.org/?tree=Try&rev=6db593b1780e
Comment 6 Matthew N. [:MattN] (PM me if requests are blocking you) 2012-02-08 00:10:31 PST
Comment on attachment 593014 [details] [diff] [review]
v.1 Show (with separator) when "Check spelling" is shown (with tests)

[Approval Request Comment]
Regression caused by (bug #): 352037 
User impact if declined: Significant usability decrease if "Add to Dictionary" is used.  The new undo option will become the top centext menu item everywhere (ie. instead of "Open link in new tab" or "Back").
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): Low risk, undo option won't show up as much
String changes made by this patch: None
Comment 7 Asa Dotzler [:asa] 2012-02-08 08:18:09 PST
I support this change. It's simple and fixes a usability regression.
Comment 8 Ed Morley [:emorley] 2012-02-08 08:58:44 PST
https://hg.mozilla.org/mozilla-central/rev/36b986ef4b5b
Comment 9 Alex Keybl [:akeybl] 2012-02-09 13:39:09 PST
Comment on attachment 593014 [details] [diff] [review]
v.1 Show (with separator) when "Check spelling" is shown (with tests)

[Triage Comment]
Given how early we are in Aurora 12, and the input from product, approved.
Comment 11 Simona B [:simonab ] 2012-04-03 06:30:09 PDT
Verified using Firefox 12 beta 3 on Windows 7, Mac OS 10.6 and Ubuntu 11.10 that -"Undo Add to Dictionary" context menu is not displayed outside of text fields.

Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20100101 Firefox/12.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0) Gecko/20100101 Firefox/12.0
Mozilla/5.0 (X11; Linux i686; rv:12.0) Gecko/20100101 Firefox/12.0

Note You need to log in before you can comment on or make changes to this bug.