Last Comment Bug 722651 - Negative uptimes reported to Telemetry
: Negative uptimes reported to Telemetry
Status: RESOLVED WONTFIX
: perf
Product: Toolkit
Classification: Components
Component: Telemetry (show other bugs)
: Trunk
: All Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-31 02:58 PST by Vladan Djeric (:vladan)
Modified: 2012-09-13 01:14 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Two Telemetry reports with negative uptimes (69.68 KB, text/plain)
2012-01-31 02:58 PST, Vladan Djeric (:vladan)
no flags Details

Description Vladan Djeric (:vladan) 2012-01-31 02:58:12 PST
Created attachment 593033 [details]
Two Telemetry reports with negative uptimes

Telemetry occasionally reports negative uptimes.

Similar to bug 670008, but the bug is still present in Telemetry reports. See attached reports from a Dec 29th and Jan 11th build.
Comment 1 Justin Lebar (not reading bugmail) 2012-01-31 07:01:41 PST
Could be bug 722625, general corruption in saved telemetry file.

It seems that there's no serious checksumming going on here.  Bits could be flipped anywhere, including in the user's RAM.
Comment 2 Lawrence Mandel [:lmandel] (use needinfo) 2012-09-12 01:56:25 PDT
Xavier - I would like to gauge how prevalent this issue is - and if it is still an issue. Can you please check how many pings in recent days (recent for whenever you get to check) include negative uptimes?
Comment 3 Xavier Stevens [:xstevens] 2012-09-12 09:49:36 PDT
This is still present but it's a pretty minor (negligible) issue in the numbers.

9/10/2012 => 401 out of 3,500,553 submissions had a negative uptime
9/11/2012 => 324 out of 3,282,940 submissions had a negative uptime

For what it's worth I'm only seeing it happen in release or beta channels.
Comment 4 Lawrence Mandel [:lmandel] (use needinfo) 2012-09-13 01:14:29 PDT
Looks like we're talking about roughly 0.01% of the population. I don't think this is worth the time to investigate at this point. I'm going to resolve as wontfix.

Note You need to log in before you can comment on or make changes to this bug.