Last Comment Bug 722656 - IonMonkey: Assertion failure: entry->prop == shape, at js/src/jsinterp.cpp:1275
: IonMonkey: Assertion failure: entry->prop == shape, at js/src/jsinterp.cpp:1275
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: David Anderson [:dvander]
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: 677337
  Show dependency treegraph
 
Reported: 2012-01-31 04:07 PST by Jan de Mooij [:jandem]
Modified: 2012-01-31 15:34 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (1.44 KB, patch)
2012-01-31 14:22 PST, David Anderson [:dvander]
bhackett1024: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] 2012-01-31 04:07:19 PST
The testcase below is reduced from tests/basic/splice-check-steps.js

$ ./js --ion -n test.js
Assertion failure: entry->prop == shape, at js/src/jsinterp.cpp:1275

Looks like there's a problem with the two NAME ops in the "note" function.
--
function f(obj) {
    var order = [];
    function note() {
        order;
        obj;
    }
    return Proxy.create({get: note});
}
proxy = f({});
for (var i=0; i<90; i++)
    proxy.foo;
proxy = f({});
for (var i=0; i<90; i++)
    proxy.foo;
Comment 1 David Anderson [:dvander] 2012-01-31 14:22:47 PST
Created attachment 593215 [details] [diff] [review]
fix
Comment 2 David Anderson [:dvander] 2012-01-31 15:34:52 PST
http://hg.mozilla.org/projects/ionmonkey/rev/4e487dfde168

Note You need to log in before you can comment on or make changes to this bug.