Last Comment Bug 722723 - Migration tool sets proxy to "None" when migrating from IE, instead of "Use System Proxy Settings"
: Migration tool sets proxy to "None" when migrating from IE, instead of "Use S...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Migration (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 710895
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-31 08:40 PST by Brian Smith (:briansmith, :bsmith, use NEEDINFO?)
Modified: 2012-04-18 14:07 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Brian Smith (:briansmith, :bsmith, use NEEDINFO?) 2012-01-31 08:40:55 PST
"Use System Proxy Settings" is almost always the correct proxy setting for Firefox. (In fact, this is the only proxy configuration that IE and Chrome support.) But, when we migrate from IE, we switch from "Use System Proxy Settings" to "No proxy" if the system isn't configured to use a proxy.

Instead, when the migration tool is migrating browser options, it should always reset the proxy items to "Use System Proxy Settings." This way, any kind of auto-configuration that is done (e.g. using connection management tools like Lenovo's ThinkVantage Access Connections) will work for Firefox automatically.
Comment 1 :Felipe Gomes (needinfo me!) 2012-01-31 08:52:44 PST
I've made this change already on the latest patch on bug 710895. See bug 710895 comment 11 for details.

The difference is that I removed all the code that imports network preferences. Since "Use system proxy settings" is the default it doesn't try to set it. Do you think we should go even further and actively reset it to "use the system settings" if it had been changed?
Comment 2 Marco Bonardo [::mak] (Away 6-20 Aug) 2012-04-18 14:07:22 PDT
we don't import anymore these settings.

Note You need to log in before you can comment on or make changes to this bug.